x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Nvidia crash on instanced foliage render

Heyo!

Problem

Currently, any attempt to render objects created with the foliage tool crashes the UE4 editor on my machine.

Reproduction

Create a new first person project, attempt to place foliage of any sort - It crashes with default settings.

Logs

MyProject.log: http://paste.orangehattech.com/view/a8557851

diagnostics.txt: http://paste.orangehattech.com/view/f2fcdd99

Versions

I am running debian 'jessie' linux.

The error occurs when using Nvidia drivers 340.65-2, 346.59, and 349.16 - The driver version doesn't seem to matter.

I have tested two different versions of UE. The first using an unmodified version of this ( https://github.com/3dluvr/UnrealEngine ) version of the unreal engine. I built from source around May 5th, and there have been no changes to the repo since then. The second was built from the mainline UE4.8 git repo, as of the morning of May 7th. The error occurs identically in both cases, but the above logs are from the UE 4.7-linux trial.

Notes

I tried numerous different meshes - Ferns, grasses, bog myrtle, chairs, the simple cube. All had the same problem.

I also tried placing the meshes on various forms of landscape, rather than the default room that UE4 provides, which didn't affect the problem.

This crash can occur instantly if the instanced rendering is enabled in the viewport, or it can be postponed until I attempt to play the game if I turn off the instanced rendering in the editor viewport, so the crash appears to be related to rendering the foliage, rather than merely placing it.

Please let me know if there's anything else I can be doing here!

Cheers,

-Dirkson

Edited May 7th to add new version attempt and use bright orange headers, like a cool kid.

Product Version: Not Selected
Tags:
more ▼

asked May 05 '15 at 09:08 PM in Using UE4

avatar image

dirkson
1 1 2

avatar image Yaakuro May 07 '15 at 11:58 PM

Hidiho here yaakuro :D

I have the same issue as mentioned in this report. With the OpenGL.UseVAB=0 it does not happen anymore.

Steps to reproduce

  • Create empty project
    • Create a cube mesh

    • My system

      Ubuntu 14.04.02 LTS 64-bit
  • Nvidia 750Ti 2GB, Driver: 349.16

  • 16GB Ram

    Crash Log

Signal 11 caught. EngineCrashHandler: Signal=11 [2015.05.07-23.46.36:120][913]LogCrashTracker:

[2015.05.07-23.46.36:120][913]LogLinux: === Critical error: === Unhandled Exception: SIGSEGV: invalid attempt to access memory at address 0x00000002

[2015.05.07-23.46.36:120][913]LogLinux: Fatal error!

[Callstack] 02 0x00007f382f048621 ReportCrash(FLinuxCrashContext const&) [Callstack] 03 0x000000000042d4ab EngineCrashHandler(FGenericCrashContext const&) [Callstack] 04 0x00007f382f04beb8 PlatformCrashHandler(int, siginfo_t*, void*) [Callstack] 05 0x00007f382fac9340 /lib/x86_64-linux-gnu/libpthread.so.0(+0x10340) [0x7f382fac9340] [Callstack] 06 0x00007f38022af964 /usr/lib/nvidia-349/libnvidia-glcore.so.349.16(+0x157f964) [0x7f38022af964] [Callstack] 07 0x00007f38022b392a /usr/lib/nvidia-349/libnvidia-glcore.so.349.16(+0x158392a) [0x7f38022b392a] [Callstack] 08 0x00007f38022c8cfb /usr/lib/nvidia-349/libnvidia-glcore.so.349.16(+0x1598cfb) [0x7f38022c8cfb] [Callstack] 09 0x00007f38026d88bd /usr/lib/nvidia-349/libnvidia-glcore.so.349.16(+0x19a88bd) [0x7f38026d88bd] [Callstack] 10 0x00007f38026df893 /usr/lib/nvidia-349/libnvidia-glcore.so.349.16(+0x19af893) [0x7f38026df893] [Callstack] 11 0x00007f38022c2ebe /usr/lib/nvidia-349/l[2015.05.07-23.46.36:124][913]LogExit: Executing StaticShutdownAfterError

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I filed UE-15240 to track this internally; there seem to be other bugs with a similar callstack. Could you check if setting OpenGL.UseVAB=0 in ConsoleVariables.ini anyhow changes the behavior?

more ▼

answered May 07 '15 at 11:08 PM

avatar image

RCL STAFF
2.7k 59 6 88

avatar image dirkson May 08 '15 at 02:49 AM

Setting OpenGL.UseVAB=0 makes the bug vanish for me. I was able to load a scene up with foliage and wander around in it. Hurrah!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question