x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

3D Widget glowing in a dark map

Hi, i'm trying to make a MainMenu with 3D Widgets but UMG images look to glow when they are rendered on a 3D Widget. I tried to change Lightmass settings but it's still glowing.

Button on UMG:

alt text

Button on the 3D Widget:

alt text

How can i do to make the 3D Widget stop making light ? Thanks!

Product Version: Not Selected
Tags:
capture2.png (6.9 kB)
capture1.png (115.2 kB)
more ▼

asked May 05 '15 at 11:24 PM in Rendering

avatar image

Enol
13 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This is probably a byproduct of Eye Adaptation (automatic exposure) and bloom:

Eye adaptation is a feature in the engine that mimics the way your eyes adjust in real life depending on how bright or dark your surroundings are. When you suddenly go from a really dark building out into bright sunlight, the outside world looks REALLY bright for a little bit while your eyes adjust. Because most of your scene is black, UE4's eye adaptation thinks you're in a dark area, so it's trying to brighten everything for you so you can see it better; hence the UI looks super bright. It would be like being in a super dark closet with just a crack of light from the outside world; the outside world would look really bright.

The glow itself is bloom. Bloom is a simulation of a real thing that happens where light going through lenses isn't all perfectly redirected. Some light gets spilled over the "edges" and appears as a fuzzy mist around the main object. On medium-bright objects, the amount of light that's spilling over is really small in comparison to the rest of the world, so you don't notice it. But the brighter an object is, the brighter (and effectively larger) its bloom becomes. And because eye adaptation is making your UI super super bright, its bloom is also becoming so bright that you notice it.

I'd suggest two things:

  1. Firstly, if this totally black world isn't actually where this UI will live, try viewing it in your actual environment. Chances are the automatic exposure won't crank everything up so bright once you get a brighter surrounding scene, and the UI might look fine. However, if your real environment will actually be this dark, do the following:

  2. Adjust your automatic exposure settings so that it doesn't adjust this much for dark scenes. I think those settings are in the camera. The link above describes it. If the camera isn't adjusting so far for dark scenes, the UI won't look white-hot and the bloom around it will probably all but disappear.

more ▼

answered May 06 '15 at 12:16 AM

avatar image

clt2488
270 17 35 37

avatar image Enol May 06 '15 at 10:16 AM

As you said, on the camera i changed the Auto Exposure settings as bellow:

alt text

And my 3D widget as no bloom anymore:

alt text

Thanks !

capture2.png (7.1 kB)
capture1.png (17.4 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

So for anyone coming across this (from a dozen other posts) and not wanting to mess up their entire PostProcess Settings:

the default 3D widget has an unlit material with an emmisive pass. Might work for most cases. Copy and change to something with an optional emmisive value, and your widget will blend in nicely with the rest of your scene.

Cheers.

alt text alt text

PS: sorry for bumping old thread

more ▼

answered Nov 02 '16 at 09:20 AM

avatar image

NanopixelKim
18 3 5 10

avatar image Jack-Chen8 Nov 17 '17 at 08:49 AM

sorry, NanopixelKim. Unable, your way is mistake.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question