x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Lightmap UV wrapping error

I recently got this error when working on a mesh, I've checked my UV unwrap both in 3ds max and in the engine for anything out of the 0-1 bounds but everything looks fine, I suspect it may be a mesh problem since other things I have unwrapped do not cause this error, although I have no idea what the cause, I've already looked over it for any obvious problems.

alt text

I've uploaded the mesh here:

https://www.dropbox.com/s/jpyllpyzmeoi9n4/House2.max

https://www.dropbox.com/s/lyjjbec8f19wm95/house2.FBX

The problem occurred not long after making modifications to the front of the house, (the area with the overhang) if anyone can take a look that would be great.

Product Version: Not Selected
Tags:
more ▼

asked Mar 31 '14 at 05:17 PM in Rendering

avatar image

Chryseus
1 1 2 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I was experiencing the same problem and I even didn't think about the lightmap index because in UDK it was always channel 1 by default. Why does U4 apply channel 0 from time to time? Is it just a bug or it depends on something when export? Thanks.

more ▼

answered Jun 05 '14 at 01:06 AM

avatar image

rambooze
41 2 2

avatar image Tim Hobson ♦♦ STAFF Jun 06 '14 at 09:52 PM

Hi Rambooze,

It's not a bug, When there is no second uv channel the engine will select UV channel 1 (Channel 0 in the engine) as the default.

When you auto generate a second uv within the editor you will have to manually change the setting from coordinate 0 to 1 for the lightmap to work.

Thank you!

Tim

avatar image rambooze Jun 08 '14 at 12:34 PM

Thank you Tim. So it means that initially I exported my objects just with one UV channel and later re-exported with two. Now it's clear to me.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I am not sure what problem you are referring to, but just an advice - pack your lightmap UVs tighter. You are wasting a lot of space there. What you can to is:

1) Select your house and apply Unwrap modifier 2) switch to channel 2, and answer "move" when asked 3) Go to face subobject and Ctrl+A to select all 4) Go to Mapping > Flatten. Use value of around 0.02-0.1 for padding, click ok. 5) Now your uvs should be neatly packed within 0-1 area with some padding 6) Collapse back to Editable mesh and reexport your object

Hope this helps.

more ▼

answered Mar 31 '14 at 05:24 PM

avatar image

BrickTop
89 16 20 21

avatar image Chryseus Mar 31 '14 at 05:45 PM

This is exactly what I did with a spacing of 0.05

In UE4 the lightmap looks all stretched which doesn't make any sense.

avatar image Alexander Paschall ♦♦ EPIC Mar 31 '14 at 06:15 PM

Hello,

Thank you for your report. I am investigating FBX issues, but I was unable to find a problem with the provided files. At what point do you get the message? Could you please provide a screenshot of the error occurring?

Thank you,

Alexander

avatar image Chryseus Mar 31 '14 at 06:43 PM

Hi

I get the error when building the lighting, here is what it looks like: http://u.cubeupload.com/Chryseus/JFJ9R6.png

http://u.cubeupload.com/Chryseus/IPgaTC.png

Nevermind I think I found the problem, I didn't realise I had to also unwrap the first UV channel as well.

avatar image Jacky Mar 31 '14 at 06:48 PM

Are you sure you have the right UV channel set for lightmaps?(you can check it in static mesh editor > Details panel > Static Mesh Settings > Lightmap Coordinate Index)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question