x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

4.8 Preview 1 - Landscape Grass Population Crash

Not 100% sure if it is only with my existing landscape and landscape material, but if I'm using my existing landscape and level. But populating grass in my existing level's landscape crashes. Tried with a new landscape and level, while it isn't nearly as complex as my original material, it seems to populate fine.

When it is compiling shaders in my existing landscape and material, it will get to maybe 50% complete, grass will be where the shaders have finished compiling, but once it gets to a certain point the editor will crash.

Product Version: Not Selected
Tags:
more ▼

asked May 07 '15 at 01:24 AM in Bug Reports

avatar image

louie9588
19 3 4 8

avatar image akka May 07 '15 at 03:28 AM

I'm having the exact same issue, it seemed to get further along when i deleted my DerivedDataCache, but still crashed before completing.

Also, now that I've "saved" my landscape material changes rather than just "applying", I can't even open my project since it starts compiling shaders as soon as it loads up, and then just crashes 10 seconds later.

avatar image louie9588 May 07 '15 at 03:55 AM

Change your default map in your config ini file so you can load the project and revert your changes.

avatar image akka May 07 '15 at 04:31 AM

Thanks, I just deleted and re-cloned my project since it was a copy of my 4.7 project anyway, but I still haven't been able to get the new grass system working :(

avatar image akka May 07 '15 at 07:03 AM

I managed to get the grass populated on my terrain by making the changes to my landscape material with no landscape in my map yet, and then re-importing the landscape.

I ran in to another issue here though as I can't seem to assign layer info or import my layer info heightmaps in the new landscape tool (that just crashes the editor as well). I had to import my landscape from the heightmap by itself, and then assign the weight blended layers and import my layer info maps one at a time.

This could be what solved the foliage crash issue as it only had to build the grass fields one layer at a time this way. Since I can't import my landscape with it's weight blend layers on landscape creation, I can't really tell.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi guys,

I'd really like to track down the cause of the crashes and get them fixed for 4.8. Would either of you be able to send me a project that crashes when you add grass to your existing landscape material? Or do either of you have a log file (in your project's Saved/Logs folder) from any of your crashes?

Thanks Jack

more ▼

answered May 07 '15 at 01:18 PM

avatar image

JackP_oldaccount
1.3k 37 11 46

avatar image louie9588 May 07 '15 at 06:22 PM

Attached is a new Logs folder containing the crash as I have been able to consistently produce. Happens even if I don't have any meshes in the Landscape Grass object. Logs Folder

Unfortunately won't be able to realistically upload my project files unless I get use of someone else's connection with a not so limited upload bandwidth.

logs.zip (60.4 kB)
avatar image JackP_oldaccount May 08 '15 at 07:37 AM

Awesome, that log provides me with exactly what I needed. It seems to be crashing for components with XY offset maps which I hadn't tested. I've filed a ticket as UE-15252 and I'll try to get it fixed in time for 4.8 preview 2.

Thanks for the bug report.

avatar image louie9588 May 08 '15 at 07:15 PM

Thanks so much. I'm looking forward to the next build if it gets that update. Testing 4.8 preview as much as I can, because the new features are something that is extremely handy for my natural environment that I'm making my own assets for.

avatar image JackP_oldaccount May 11 '15 at 03:13 AM

This crash was fixed today and should be in preview 2. The fix is here if you are using Github.

https://github.com/EpicGames/UnrealEngine/commit/e97f17dfc51fe9889c62d0fbc542e65a17fdd468

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question