x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Open Level broken on android

'Open Level' node works fine PIE but packaged on android it never loads the new map.

  • Unreal engine 4.7.6

  • Google Nexus 4 (5.1)

  • All texture compression is on 'default'

This is my main menu UI button code. SetGameState sets all UI to hidden then turns on only the ones it needs for the current state.

alt text

alt text

logcat while building for android, opening app, trying 'open level' button, closing app

PIE log while building for android

Product Version: Not Selected
Tags:
1_newgame.png (74.8 kB)
2_openlevel.png (223.2 kB)
android_log.txt (192.7 kB)
pie_log.txt (849.9 kB)
more ▼

asked May 07 '15 at 07:00 AM in Bug Reports

avatar image

Neros_
279 29 42 54

avatar image wittlief ♦♦ STAFF May 07 '15 at 06:04 PM

Hi Taisaku,

Can you show a screenshot of your Blueprints setup? For what compression texture are you packaging? What device are you testing? You say it never loads, does it crash or black screen or some third option?

Can you include the build output logs and also the device's logcat logs to this thread as a txt file?

Thanks!

avatar image Neros_ May 08 '15 at 12:21 AM

I have a UI button that triggers 'Open Level' node, in PIE when i click it it loads the next map, but on android my menu state changes to the correct thing and waits for the map to load, then nothing happens for a second or two, then it loads back up at the previous menu state which I think means the program is restarting.

I'll get some BP screenshots and things up sometime in this coming week.

avatar image Neros_ May 08 '15 at 04:21 AM

Updated Question with info.

avatar image wmbuRn May 08 '15 at 07:33 AM

Did you lauch your game to device or did you build android version and than installed the .apk? If you did the throught the launch, somtimes it happends that it doesnt load the maps, so please build .apk and install it on device and test (:

avatar image Neros_ May 08 '15 at 08:33 AM

For some reason when I try build APK it gives me a huge list of:

LogLinker:Warning: Can't find file

Which are all pointing to files that have been moved or deleted. I did a 'Fix up redirectors in folder' on my entire content folder and I still get these errors. Also even with these errors it still runs PIE which is a little weird.

avatar image wittlief ♦♦ STAFF May 12 '15 at 09:45 PM

Hi Taisaku,

Can you attach the output log of your apk build to this thread as a txt file?

avatar image Neros_ May 12 '15 at 11:09 PM

It's already attached as pie_log.txt

avatar image Neros_ May 12 '15 at 11:19 PM

Here's another one I just tried link text

apk_build.txt (1.3 MB)
avatar image wittlief ♦♦ STAFF May 13 '15 at 03:02 PM

You're getting a lot of errors like:

LogUObjectGlobals:Warning: Failed to load '/Game/bZerk/Characters/Brom/BromSkeleton': Can't find file '/Game/bZerk/Characters/Brom/BromSkeleton'

As the fix up redirectors isn't completely repairing this, you should be able to remove these files through the filepath on your desktop. Go to \Unreal Projects\PROJECT NAME\content\ and find the folders where the assets were stored. See if you can see those assets and remove them manually.

Also, and this shouldn't be causing your failed build but will cause problems for a mobile project down the road, I see a number of errors like:

LogMaterial:Warning: (Node Noise) Node not supported in feature level ES2

There are some limitations for mobile development that affect assets, textures, lighting, etc. Please have a look at the General Mobile Development documentation for those limitations. For reference, here also is the Mobile Dev Troubleshooting Guide for some general known issues, and problems with specific devices.

Hope this helps!

avatar image Neros_ May 13 '15 at 11:42 PM

I have tried to cleanup those redirects as best as I can, but the build still fails with the same errors, it keeps pointing to files that don't exist and no objects are referencing.

It looks like all the errors are coming from 'StaticMeshComponent0' is there some way i can track that down?

Also I had a thought about redirectors, wouldn't it be much cleaner and easier to manage if they were all in one database file rather then split into individual files? it may make it a little more annoying to fix through multiple user version control, but you would never run into bad redirection chains.

avatar image Neros_ May 14 '15 at 12:19 AM

I just tried to update my project from 4.7 to 4.8 to see if anything would change, it looks like the redirector errors have dissapeared but its still not building.

47_48_conversion_first_open

48_android_build

UnrealBuildTool_log

avatar image Neros_ May 14 '15 at 12:56 AM

and now i cant even PIE, UI complains that another UI hasn't been compiled, so i hit compile and it crashes every single time :<

avatar image wittlief ♦♦ STAFF May 14 '15 at 06:31 PM

Hi Taisaku,

When you updated did you convert your project or did you make a copy? If it is the former, do you still have the 4.7.X version of your project that you can copy and try to open in 4.8? Do you still have the 4.7 version of the editor on your machine?

Can you reproduce this in a clean project with no additional content or does this occur only in one project?

avatar image Neros_ May 15 '15 at 12:11 AM

I'm using perforce so rolling back is not a problem. I have 4.7.6 and 4.8P2 both available.

I can reproduce this in a clean 4.7.6 3D sidescroller template. It does the same thing as i originally described. Here's a zip of the clean project - https://drive.google.com/file/d/0B9U7rcZaCw8CU1MxdUsyNUtoeEE/view?usp=sharing

Here's a log to go with it

Converting this project to 4.8 does the same thing.

I opened 4.8P2 and then opened a copy of my 4.7.6 project, when i go to compile it says my SystemMenuUI menu has an error

alt text

So I open up my PlayerDataItem and everything looks fine.

alt text

So I think there's a bug and in addition my project is corrupted.

avatar image wittlief ♦♦ STAFF May 15 '15 at 02:07 PM

Hi Taisaku,

That appears to be your PIE log again, and it says successful, so are you still seeing a compile crash, or just the above error when you attempt to compile?

I do not immediately see anything wrong in the PIE logs, and I don't see your 'failed to load' errors anymore. Is that blueprint compile error the only thing wrong now? I am assuming you're no longer getting PIE crash if you're able to provide PIE logs. Are you able to package as an apk?

Thanks

avatar image Neros_ May 15 '15 at 02:22 PM

That log is for the new clean project, it builds fine but the OpenLevel command fails like it did in my initial post.

My project still has build errors.

avatar image Rudy Q ♦♦ STAFF May 19 '15 at 07:36 PM

Hello Taisaku,

I was looking over your post and I saw that you had reported an issue with the UI throwing error after upgrading from 4.7.6 to 4.8. The error that was shown in your screen shot is a known issue. You can delete any variable that are being pulled out of the widget and simply recreate them. This will allow you to clear of up those errors. I hope this helps.

Make it a great day

avatar image Neros_ May 20 '15 at 01:28 AM

That issue is very minor, i can work around it.

The problem is i still can't build my game for windows or android, and that OpenLevel still fails even in a clean project.

avatar image Rudy Q ♦♦ STAFF May 20 '15 at 12:50 PM

Hello Taisaku,

When your open level fails, is this after you have done a launch on to test it on the device or did you actually get it to package out and install it on the device? If you are doing launch on, this will most likely fail (open level). Launch on usually only loads up the current map. Could you also try connecting a print string to your casting node's (BromUI) cast failed pin to make sure that this is not were your issue in occurring.

avatar image Neros_ May 20 '15 at 11:06 PM

I can't test that because of the build errors. It's like the engine thinks there's redirectors but there aren't. I've looked through my folders and deleted anything that looks remotely like a redirector and i still get errors saying that it can't find files that have been renamed or deleted. Fix redirects in folder does nothing, turning on the show redirectors filter shows nothing.

It might be better if i email you a copy of the project so you can take a closer look.

avatar image Neros_ May 22 '15 at 03:25 AM

I've managed to get it to build again, there was a BP referencing something that had moved, it should have thrown up compile errors but it didn't.

I packaged it for android and installed and it does the same thing as launching.

If the cast failed it would never change the UI, which it does do, but because the level doesn't open it reverts back to the main menu which reloads the menu UI again.

avatar image Rudy Q ♦♦ STAFF May 22 '15 at 03:24 PM

Hello Taisaku,

I downloaded the sample project that you used to test the issue on your device. I do not have access to a Nexus 4 and to my knowledge it is not on the list of recommended/test devices. I did however go through and test it on later devices (Starting with the Nexus 5 and going up to a Nexus 9). The sample project worked without any issues on all devices. Would it be possible for you to try your project on a newer device? This will help narrow down where the issue is occurring.

avatar image Neros_ May 25 '15 at 01:13 AM

Unfortunately I don't have access to any newer Android devices.

I tried to package the test level I posted via Google Drive into an APK and run it on my Nexus 4 and it crashes on launch.

If i launch on device it loads but OpenLevel still fails.

I also tried packaging and running my main project on an older Samsung Galaxy Nexus and it crashes on load with the error:

Failed to open descriptor file '../../../bZerk_proto5/bZerk_proto5.uproject'

Hopefully sometime soon I will have access to an Apple dev key and a tablet to test on.

avatar image Neros_ Jun 02 '15 at 03:34 AM

If i package my OpenLevel test project (ETC1) for a Nexus7 tablet (copy paste apk and obb, bat still does nothing) and install then launch it says "Unfortunatly, android_openLevel has stopped." every time.

I can however launch it from editor, and it opens, but OpenLevel command just returns me to level1 just like in my main project.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Taisaku,

After looking over all of the information provided I feel comfortable saying that this issue is due to it being run on the Nexus 4. Unfortunately this is not a device that is supported. However, I would like to assist you further once you are able to test this issue on the newer devices you mentioned above. I am going to mark this issue as resolved until then. If the issue persists (on the other devices) please feel free to reopen this issue and I will be more than happy to help you further.

more ▼

answered May 28 '15 at 07:08 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

avatar image Neros_ May 28 '15 at 11:35 PM

Will do.

Do you have any idea why the Nexus 4 would be much different to the 5? They both run native Android.

avatar image Rudy Q ♦♦ STAFF May 29 '15 at 04:06 PM

Hello Taisaku,

I was able to test a device with a similar GPU and did not run into the issue that you are seeing. I do have a quick suggestion that will help give us a little more insight into the issue that you are seeing. Could you trying packaging it out using the ETC1 Compression settings?

alt text

Make it a great day

avatar image Neros_ May 30 '15 at 12:58 AM

I built with ETC1 and copied the APK and OBB to my Nexus4 but when i click on the APK and hit install, it runs for a while then says "App not installed."

ATC also fails to install.

If I build for 'all' it installs but OpenLevel fails.

avatar image Rudy Q ♦♦ STAFF Jun 01 '15 at 02:31 PM

Hello Taisaku,

I noticed that you didn't say that you ran your .bat file. So could you try using the following steps to package out your project?

Try the following steps:

  1. Connect the device to your computer

  2. Remove all old versions from your phone

  3. Use a new folder location or clean out the old version in your previous folder location that is used for packaging

  4. Package for ETC1

  5. Open your folder location after packaging

  6. Run your .bat file

  7. Open the app on your device

avatar image Neros_ Jun 01 '15 at 11:40 PM

bat opens and closes instantly without installing app to phone or giving error messages.

avatar image wittlief ♦♦ STAFF Jun 02 '15 at 02:12 PM

Hi Taisaku,

Can you get debug logs from ADB monitor/logcat for your Nexus 4 and post them here as a txt file?

Thanks!

avatar image Neros_ Jun 02 '15 at 11:28 PM

I cleared the log then launched from editor and got this

Cleared again and launched bat (ETC1), log was completely empty.

Cleared again and installed from copy pasted (ETC1) APK and OBB, got this


[logcat1.txt Line 1143] LogNet:Warning: Travel Failure: [InvalidURL]: Invalid URL: /Game/bZerk/Maps/MainMenu

Looks like it thinks my map urls are invalid. Here's my map locations, they look ok to me. alt text

logcat1.txt (79.3 kB)
logcat2.txt (83.9 kB)
maps.png (40.1 kB)
avatar image wittlief ♦♦ STAFF Jun 08 '15 at 04:16 PM

Hi Taisaku,

When you said you copy pasted the APK and OBB, what do you mean? How did you install the apk without the batch file?

Can you package your project and try installing to the device via the batch file with monitor running once more? If it still isn't working or showing anything in the monitor when you run the batch file, can you send us your project or the .apk of your packaged project via a file transfer like Google Drive or Dropbox?

avatar image Neros_ Jun 08 '15 at 11:44 PM

Copy paste via usb from my pc into a folder on my phone storage, then run the apk, it asks to install. Or use 'ES File Explorer' on phone to access pc via wifi.


This is android_openlevel a clean 3d sidescroller with the minimum implementation of what im doing in my main project, it breaks in exactly the same way.

In PIE it runs and the button works. Launch onto Nexus4 from editor it runs but the button does not take me to the next level like it should. Copy paste all to phone and run APK installs but wont run at all.

Running BAT on its own does nothing. Running bat from CMD still does nothing but at least it doesnt close the window. alt text

(ETC1) APK, OBB and BAT here - https://drive.google.com/open?id=0B9U7rcZaCw8CU1MxdUsyNUtoeEE&authuser=0

Project files here - https://drive.google.com/open?id=0B9U7rcZaCw8CanFxU1NOd09ZNFk&authuser=0

capture.png (38.3 kB)
avatar image jwatte Jun 09 '15 at 01:18 AM

When "launch from editor" starts, it means only the current level is transferred, and apparently that level works.

When "Open Level" fails, it either means that the level file wasn't transferred (launch from editor) or it contains incompatible assets (if you built and installed.)

You should run the BAT file from a command line window, not just double-click it. That will let you see what it prints out and what it's trying to do.

Also, you should run "adb logcat" in another command line window when trying to install the game or run it from the install. This will capture log messages that quite possibly can show you what the problem is -- texture resolution too large, texture format wrong, meshes too large, out of memory, ...

If you compare the Nexus 4 and Nexus 5, you will find that the Nexus 5 has a newer GPU (Adreno 330, as opposed to Adreno 320 in the previous one.) This may be similar to trying to run a "shader model 10" game on a graphics card that only supports "shader model 9." http://www.phonearena.com/phones/compare/Google-Nexus-5,Google-Nexus-4/phones/8148,7531

avatar image Neros_ Jun 09 '15 at 01:31 AM

Most of this has been addressed already in earlier comments.

I'm aware that running new code on old platforms typically doesn't work.

I'm just not convinced that this is the case yet seeing as you can tell the editor to compile for gingerbread (v9) and my nexus4 is running lolipop (v21)

Also everything else is working, the only command that is broken should be easily fixable once they can track down why its not working.

avatar image jwatte Jun 09 '15 at 01:53 AM

The version of Android is orthogonal to the version of hardware. You can run a late version of Windows on hardware with an old graphics card. The real answer will hopefully come from looking at "adb logcat"

avatar image Neros_ Jun 09 '15 at 02:33 AM

I posted logcats in earlier comments, if you can find anything in them that will help, that would be great.

avatar image jwatte Jun 09 '15 at 03:39 PM

Closest I can find:

 W/ResourceType(  728): No package identifier when getting value for resource number 0x00000000
 W/PackageManager(  728): Failure retrieving resources for com.RuffHaus.bZerk_proto5: Resource ID #0x0

Also:

 I/adblock.(26451): false: http://hmma.baidu.com/app.gif

Are you using a rooted device?

 D/UE4     ( 1562): [2015.06.02-23.26.54:771][  0]LogInit: Applying CVar settings loaded from the selected device profile: [Android_Adreno320]

Seems like the 320 should be supported (or, at least, was at one point supported...)

 D/UE4     ( 1562): [2015.06.02-23.26.54:789][  0]LogTextLocalizationManager: The requested culture ('en_AU') has no localization data; parent culture's ('en') localization data will be used.

Could this be a US-versus-AU-locale problem? Paths different? Some other data format different? Can you reset the phone to a factory image (non-rooted) with US locale, and see if it works after running the BAT file to install the package? If so, the problem is isolated.

Other than that, I probably can't help more -- opening levels from menu buttons works for me in my app (4.7.6)

avatar image Neros_ Jun 09 '15 at 11:52 PM

Not sure what that resource identifier is, its pointing to 0x0 anyway, possibly a bad pointer somehow?

Yes phone is unlocked, but its still running stock android.

The localisation stuff will just be complaining about not finding matching strings for the text boxes, the map names aren't being used like that so its doubtful that its the problem.

Thanks for these, maybe a staff member will have a better understanding.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question