x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.8P1] Physics bugs

I have found two strange physics bugs in the 4.8 Preview 1.

One is if you spawn a physics actor which has simulate physics disabled at location x, then set the location to y and then enable simulate physics, it is again at location x.

Another bug is, if you set simulate physics to off in the details panel, and additionally set simulate physics off in event begin play, then you can't enable physics later, it just stays disabled.

Here you have a clean repro project for both bugs:

https://drive.google.com/file/d/0BzqDz_3FVfpOeFMxVFdnOTdVSFU/view?usp=sharing

Just hit play, you see the stone falls correctly. Then go into the "Stones" blueprint and connect the exec wire from EventBeginPlay to the stuff inside of the "DoesNotWork" Comment. Then hit play, you see you can't see the Stone because it's at location 0/0/0.

For the other bug, connect the wire in Stones back to working and open the Stone blueprint and connect the wire at EventBeginPlay to the SetSimulatePhysics Node. Then hit play, you see the Stone does not move because physics is disabled, even though SetSimulatePhysics(true) gets called in the Stones blueprint.

Product Version: Not Selected
Tags:
more ▼

asked May 07 '15 at 10:12 PM in Bug Reports

avatar image

John Alcatraz
1.3k 58 139 127

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi John,

Thank you for the report.

Issue #1: I created JIRA UE-15268 and our developers will be investigating it further. We will post back here with updates as we have them.

Issue #2 : Is actually the intended functionality. What you are seeing is how the events stack.

  1. The 'Spawner' blueprint spawns the 'Stone' bp

  2. The 'Spawner sets 'Simulate Physics' to Enabled

  3. Then the 'Stone' bp's 'Event Begin Play' kicks off and disables physics

I hope that helps clear up what is going on. Thanks again for the report.

Cheers,

TJ

more ▼

answered May 08 '15 at 03:03 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image John Alcatraz May 21 '15 at 05:51 PM

Hi TJ, I saw this commit: https://github.com/EpicGames/UnrealEngine/commit/ff3784b50de9f582eecaac3aef2cfb68b7128409 It seems to be like a fix for UE-15268 except that it's about destructibles, not physics actors. If this commit related to UE-15268?

avatar image TJ V ♦♦ STAFF May 21 '15 at 06:54 PM

Hi John,

No that commit is for another JIRA. It is specifically for the SetWorldLocation node not working for destructible actors.

It seems very similar in origin to your issue so it will likely help him narrow down the fix.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question