x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.6] Separate Translucency Not Working


It appears that Separate translucency is being ignored.


Because of the known issues with Depth of Field and translucent materials (particles being read as if they are distant)

I have been trying to force particles to ignore DoF - which is supposed to work by using separate translucency.

However, despite ensuring all my settings are correct, my particles are still being blurred.


Below is an image showing my settings, as well as the result.


alt text

Product Version: Not Selected
Tags:
untitled-1.png (2.1 MB)
more ▼

asked May 08 '15 at 11:33 AM in Bug Reports

avatar image

Kenomica
434 40 40 46

avatar image Lovecraft_K ♦♦ STAFF May 08 '15 at 04:10 PM

Hi Kenomica -

I am not having any issues with the DOF and Particles rendering correctly. Can you take a look at this test project (attached below) and see if you have a setting that I am not duplicating?

Thank You

Eric Ketchum

Test Project 4.7.6

ah_dofdinosaur.zip (787.0 kB)
avatar image Kenomica May 09 '15 at 01:37 AM

Hey, thanks for the reply and the helpful project.

Everything works completely as expected in the project you sent me - I also tested in the project using a camera as opposed to a post process volume as that's the only difference I could find between the test project and my own.

It still worked correctly in the test project.

the strange thing is, this issue occurred seemingly at randomly. I have other particles in other scenes, which worked correctly. it was only after I created a new particle system (the bubbles) that I was confused as to why they were being blurred. Then on my next play test, suddenly all particles exhibited this behaviour (despite them not being edited in any way - material or particle system)


EDIT : Oddly, I have one particle system that DOES work as intended. I check "Separate Translucency" and no Depth of Field, Uncheck it, Depth of Field. yet all other particle systems will not do the same.


EDIT 2 : After finding that one particle system used separate transparency with no problems (WAI), I set other systems where it does not work to use the material that works in the WAI particle system - It did not work. So maybe the issue is in the particle system itself, NOT the material.


EDIT 3 : Here's something really interesting - I migrated one of my particle systems to your project. I changed none of the settings in the project.

Somehow, simply migrating my particle system and placing it in world caused your particles to ignore Separate Translucency at certain angles.

I have attached the project with my migrated particles.


Test Project with Migrated Assets

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Kenomica -

This is a bug with Separate Translucency Rendering and the use of Scene Color, which is why when you imported your Particle into the test map, the test map broke. You material is using Scene Color for the Chromatic Aberration which currently means that Separate Translucency will not work on any particles. I have entered a report, UE-15433 for reference, and will keep you up to date as we investigate a solution.

Thank You

Eric Ketchum

more ▼

answered May 12 '15 at 02:22 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

avatar image Kenomica May 12 '15 at 08:21 PM

Thank you, I'm glad we were able to get to the bottom of it and that a bug has been filed. At least I can temporarily disable the Chromatic Aberration in the material until a a fix is applied.

avatar image eric_brb Jul 05 '17 at 10:02 PM

I encountered the incompatibility of scene color and separate translucency in 4.14 and found that this bug is still flagged as "won't fix". I have been trying to optimize particles and other translucent materials by using a lower-resolution transparency pass (proving to be especially necessary for VR), but, as soon as a scene color node is introduced (which may be necessary for a couple of the effects I have been attempting), the material drops out of separate translucency and back into the full-res (or, in our case, higher than full res) main pass.

Additionally, I am finding that using a scene color node requires that I either change r.SceneColorFormat to 4 (from 2) or set r.ParallelTranslucency to 0. If I don't, I get flickering on any translucent material that uses a scene color node...which may relate to this issue: https://answers.unrealengine.com/questions/529243/parallel-translucency-causes-flickering.html

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question