x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.8p1] Components on any BP Actor: property change causes focus change or deselection

Version: 4.8 Preview 1 (Version: 4.8.0-2536902+++depot+UE4-Releases+4.8)
Launcher Build on Windows 7 x64

Inside the any Blueprint, selecting the a Component works as expected - the Details Pane shows all the stuff exposed to us. But whenever a property is changed, some sort of refresh happens that makes the Pane lose focus for a brief amount.

The most obvious one is the Movement Component of a Character (either the default one, or a derived one such as the Rotation or Projectile Movement), where changing a value (for example, toggling "Can Walk off ledges" from default on to off or changing the walk speed to a different value) causes the Component to lose focus/become deselected and the Details Pane is cleared.

This tends to be very annoying during the initial setup of a character; especially when fiddling around to get just the right values.

But this also happens for other Components, most notable reproducible with ones having a spinner-control that allows for MouseButtonDown-DragAround to change the value (such as Camera FOV, SpringArm Length, Arrow Size or even Rotation). Doing that (for example, clicking into the Size field of an Arrow component and dragging to the right) causes the change to be accepted of some sort, but the editing stops immediately and the Viewport tab flashes briefly.
Doing the same in the main editor viewport gives a smooth change with immediate preview, as it did in 4.7.

Product Version: Not Selected
Tags:
more ▼

asked May 08 '15 at 07:22 PM in Bug Reports

avatar image

BhaaL
146 8 11 20

avatar image Samantha Sutton ♦♦ STAFF May 11 '15 at 08:14 PM

Hey BhaaL,

I'm currently trying to reproduce this in Version: 4.8.0-2536902 as well. When my details pane refreshes, it doesn't change any of the properties that I'm not using. It also doesn't focus out of the details pane. It's a quick flash of refresh. Is the flash of refreshing the details pane what is causing trouble for you?

Looking forward to hearing from you! :)

avatar image BhaaL May 12 '15 at 06:10 PM

Hi Samantha,

Alexander just said on the stream that this one is known to you guys already, so I guess there are other reports out there. For the record, it just (literally right now, on the Twitch Training stream) happened to Ian while changing some AI Perception properties.

Do you still need more input from me, or is this enough to find the related issue?

  • BhaaL

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey BhaaL,

Thank you for the update! I wasn't able to find it due to the way it was worded in the summary. :) I have found the bug now and it is indeed in Jira and waiting to be worked on at this time. For your reference, the Jira report is: UE-14772

Also, I see the other reason why I wasn't able to reproduce it. I followed your directions specifically and did not compile. That seems to be when the issue appears.

All is good with this post now, since we know it's reported. Let me know if you have any further questions though! Have a great one!

more ▼

answered May 12 '15 at 07:19 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question