x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't bake foliage lightmap.

Hi,

I'm having a lighting issue. After rebuilding, my foliage is still not baked and I keep getting the error "Maps need lighting rebuilt."

I have two lights. One directional light and one sky light, and both are stationary.

alt text

alt text

Product Version: Not Selected
Tags:
more ▼

asked May 10 '15 at 12:48 PM in Bug Reports

avatar image

Ray Le
1 1 2 4

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey Ray Le,

Would you mind showing me the 'Foliage Instance Settings' you are having trouble baking lighting? Be sure you have the 'Allow Static Lighting' is enabled within your 'Project Settings' to allow your project to bake lighting. You might also want to check your 'World Settings' in case you enabled the 'Force No Pre-computed Lighting' option.

Lightmass World Settings

alt text

Allow Static Lighting

alt text

Let me know when or if you have checking these settings and still are not able to generate lightmaps for your foliage

Thank you,

Andrew Hurley

more ▼

answered May 11 '15 at 02:39 PM

avatar image Ray Le May 11 '15 at 07:03 PM

Hi Andrew,

My lighting settings are a little bit different but yes I have "Allow Static Lighting" enabled. I just find out that If I restart UE4 and reopen my project, then I can generate lightmaps for my foliage. If I build lighting again, it won't work.

Now everytime I want to build my lighting, I have to restart UE4. It's quite annoying. alt text

lighting.png (15.9 kB)
avatar image AndrewHurley May 11 '15 at 07:39 PM

Okay, thank you for checking in the suggested location. What version of the engine are you using?

Would you be able to reproduce this in a blank project? If so, could you provide me with some short and simple steps in order for me to get the issue to occur on my end as well?

avatar image JoeWintergreen Nov 17 '15 at 04:15 AM

I just ran into this in 4.10. Still a thing.

avatar image AndrewHurley Nov 17 '15 at 02:51 PM

Hey Joe,

If you are experiencing the same/similar issue, could you please provide some context and screenshots so I can take a look at your specific set up.

Also, how are you applying your foliage to your landscape?

  • Procedurally generated using the Foliage Type

  • Procedurally painted foliage using the Landscape Grass Type

  • Hand painted using the Foliage Mode

Cheers,

Andrew Hurley

avatar image Ichijo_Norifusa Jul 14 '16 at 11:25 PM

4.12.5 This appeared after reaching high count of trees painted

How it looks

Lightmap density

Lightmass world settings

Foilage painting settings

avatar image Ichijo_Norifusa Jul 15 '16 at 09:07 AM

After changing skylight mobility to static foilage has working lightmaps.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question