x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.7.6] Black Screen on Android casting c++ class to blueprint

[Version 4.7.6]

I have been struggling with this issue for a while. My project was built on the Puzzle Blueprint prototype and I was able to deploy correctly this basic project on my Nvidia Shield Tablet. I have no compiling errors and everything works fine in-editor, but deploying on my device results in permanent black screen. I tried to regress to previous stages in order to understand the source of the issue. I have a grid defined in c++ that spawns tiles, which are defined in a c++ class as well; the tile class contain a grid variable. Then I extended these two basic classes in blueprints, and when I try to cast the grid variable belonging to the blueprint tile class into the blueprint derived grid class, black screen starts appearing. If I remove the casting (leaving the reference), everything is fine. I read that many people are experiencing black screens in 4.7, so I tried the 4.8 preview, with no luck.

Any ideas?

Product Version: Not Selected
Tags:
more ▼

asked May 10 '15 at 03:09 PM in Packaging & Deployment

avatar image

Rask
33 1 5 9

avatar image Rask May 12 '15 at 01:54 PM

Notes:

  • Already tried disabling 'mobile HDR'.

  • The default map is set correctly.

  • Changing the deploying options does not change the result.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello Rask,

Would you mind testing to see if you still get this error when packaging with engine version 4.9.2?

Thank you,

Andrew Hurley

more ▼

answered Oct 11 '15 at 07:34 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question