Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Localization Setup

I'm trying to fully localize my game and i've done the following steps:

  • Set each text shown to the user as Text variable

  • Setup the game script in Config/Localization/Game.ini

  • Run the gather text commandlet

  • Localize all the .archive generated on Content/Localization/Game

  • Run the gather text commandlet again so it exports the text (? this step is not clear to me but i read it somwhere else)

Now if i run my game usin -game -culture=es, my game runs in spanish which is the language i'm trying to localize to. However what i want to do is that when the game is launched on the device (Android) it runs automatically on spanish if the device's culture is spanish or otherwise runs in english which is the default language. Tried packaging my game an running it on a device with language set to spanish but the game shows in english.

Product Version: Not Selected
more ▼

asked May 10 '15 at 06:04 PM in Packaging & Deployment

avatar image

198 38 36 43

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I figured it out, I'm going to post my solution here in case someone needs it or if a staff member comes and tell me if this is the right way. So, besides doing the above, i added the localization folder to the project packaging settings in Project Settings -> Packaging -> Add aditional asset directories to cook and also in the Add aditional non-asset directories to cook below .

more ▼

answered May 11 '15 at 07:51 AM

avatar image

198 38 36 43

avatar image Sarge STAFF May 11 '15 at 02:56 PM

That's interesting as that directory should be automatically included for packaging. Which version of the engine are you using?

avatar image DylanVelez May 11 '15 at 08:08 PM

I'm using version 4.7.6, i thought it would be included by default too but after doing what i said in the answer it worked correctly, otherwise it always falls back to default culture.

avatar image wettrix Jul 06 '15 at 06:58 AM

I had the same problem on my android in 4.8. But this totally fixed it. Nice catch.

avatar image [Phosphor]Sheevok STAFF Jul 20 '15 at 10:13 PM

This shouldn't be necessary, as the Packaging settings page already exposes some settings to control which cultures have their localization data get packaged. The fact that this fixed your issue suggests that localization data wasn't getting packaged up at all. Does it work if you make sure that the foreign culture's localization data is selected for packaging and internationalization support is set to EFIGS (if the culture is one of those)?

I've just tested with 4.8.2 and, using the Packaging settings I described, had no problems.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question