x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

GatherText rolling back to previous localization

I have my game already localized but it has some spelling errors in my localization that i wanted to get right ( the game supports both english and spanish). I ran the GatherText commandlet several times and it was working, now all of a sudden, when i try to correct a mistake or add a new text, it reverts to a past localization in a matter of speaking. Let's say i have the following Text in my ./Content/Localization/Game/es folder

 "Source":
             {
                 "Text": "Best times"
             },
             "Translation":
             {
                 "Text": "Mejores tiempos"
             }

and i want to change it to

 "Source":
             {
                 "Text": "Best times"
             },
             "Translation":
             {
                 "Text": "Mejor tiempo"
             }


after i make the change i run the GatherText commandlet again ( i don't know if this has to be done but i believe it's so it applies the changes) and when i open again the .archive it keeps showing the first localization with " Mejores tiempos" .

I don't see anything weird in the log file: link text

I have included the Content/Localization Folder in the directories to cook ( both assets and non-assets options)

I'm running the commandlet like this

 "C:\Program Files\Epic Games\4.7\Engine\Binaries\Win64\UE4Editor.exe" "C:\Users\dylan\Documents\Unreal Projects\HueRun\HueRun.uproject" -run=GatherText 
  -config="C:\Users\dylan\Documents\Unreal Projects\HueRun\Config\Localization\Game.ini" -log

Product Version: Not Selected
Tags:
huerun_2.log (22.9 kB)
more ▼

asked May 11 '15 at 09:37 AM in Bug Reports

avatar image

DylanVelez
198 38 36 43

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Everything seems correct to me.

The game only reads in the *.locres files, so if you haven't rebuilt them or are failing to rebuild them then this would certainly be the issue.

Looking at the log you posted though it appears you are successfully generating new locres files, as the last step of your gather config.

Perhaps you are doing an import from your old files which is overwriting your updated translations?

more ▼

answered May 11 '15 at 03:02 PM

avatar image

Sarge STAFF
627 14 5 36

avatar image DylanVelez May 11 '15 at 07:38 PM

This is my Game.ini file, i don't really know much about how to set it up so i just copied the one from the documentation:

 ;Common settings to be used for all commandlets as needed.
 [CommonSettings]
 SourcePath=./Content/Localization/Game
 DestinationPath=./Content/Localization/Game
 ManifestName=Game.manifest
 ArchiveName=Game.archive
 ResourceName=Game.locres
 PortableObjectName=Game.po
 ;English
 SourceCulture=en
 ;English
 CulturesToGenerate=en
 ;Spanish
 CulturesToGenerate=es
 
 ;Gather text from source code and configuration files.
 [GatherTextStep0]
 CommandletClass=GatherTextFromSource
 IncludePaths=./Source/
 IncludePaths=./Config/
 ExcludePaths=*/Config/Localization/*
 SourceFileSearchFilters=*.h
 SourceFileSearchFilters=*.cpp
 SourceFileSearchFilters=*.ini
 
 ;Gather text from assets in content.
 [GatherTextStep1]
 CommandletClass=GatherTextFromAssets
 IncludePaths=./Content/
 ExcludePaths=*/Content/Localization/*
 PackageExtensions=*.umap
 PackageExtensions=*.uasset
 
 ;Create manifest with all gathered source text.
 [GatherTextStep2]
 CommandletClass=GenerateGatherManifest
 
 ;Create new archives/update existing archives with new entries from the manifest.
 [GatherTextStep3]
 CommandletClass=GenerateGatherArchive
 
 ;Import new translations from PO (portable object) files into existing archives.
 [GatherTextStep4]
 CommandletClass=InternationalizationExport
 bImportLoc=true
 
 ;Export new source from existing archives into PO (portable object) files.
 [GatherTextStep5]
 CommandletClass=InternationalizationExport
 bExportLoc=true
 
 ;Compile source text and translations into binary form for use by the application.
 [GatherTextStep6]
 CommandletClass=GenerateTextLocalizationResource
avatar image Sarge STAFF May 11 '15 at 07:53 PM

Yeah, so your 4th step is importing the Game.po file next to your archive. If you are changing the translation in your archive then that import is stomping on it as your po file has the old translation.

Temporarily remove that, or make changes to your po file instead of the archive.


Is the translation in the archive being reverted to the old version?

avatar image DylanVelez May 11 '15 at 08:06 PM

Changing the .po file did it for me, so should i keep changing it instead of the .archives?

avatar image Sarge STAFF May 11 '15 at 08:07 PM

I would recommend that as the easiest approach. The archives weren't really intended for manual editing by translators.

avatar image DylanVelez May 11 '15 at 08:09 PM

Oh ok, thank you very much.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question