x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Get Http Module to work with HTTPS

Hello, My project use http module to do GET/POST to a https server. Here is the sample code:

         void WWW::request(string url, WWWForm f, std::function<void(WWW*)> pOnHttpResponse){
                 TSharedRef<IHttpRequest> HttpRequest = FHttpModule::Get().CreateRequest();
             
                 HttpRequest->SetHeader(TEXT("Content-Type"), TEXT("application/x-www-form-urlencoded"));
                 HttpRequest->SetURL(url.c_str());
                 HttpRequest->SetVerb(TEXT("POST"));
             
                 FString fs(f.getPost().c_str());
                 HttpRequest->SetContentAsString(fs);
             
                 HttpRequest->OnProcessRequestComplete().BindLambda([&, pOnHttpResponse, f](FHttpRequestPtr HttpRequest, FHttpResponsePtr HttpResponse, bool bSucceeded)
                 {
                     if (!bSucceeded) {
                         GEngine->AddOnScreenDebugMessage(-1, 5.f, FColor::Red, TEXT("Request failed"));
                     }
                     else
                     {
                                GEngine->AddOnScreenDebugMessage(-1, 5.f, FColor::Red, TEXT("Got something here!"));
                     }
                 });
             
                 HttpRequest->ProcessRequest();
         }

Basically, i want to send a form to the server and get a response back. The code above works flawlessly on PC , no problem whatsoever. When i deploy my game to Android , the request always fail. When i switched the url to something like "http://something.com", i got a response. Switched it back to my https server, or any https page, and it will fail. I tried the solution posted in this thread : https://answers.unrealengine.com/questions/72976/using-http-module-on-android.html , but no luck. My UE4 version is 4.7.6 . How do i solve this ?

Product Version: Not Selected
Tags:
more ▼

asked May 11 '15 at 10:36 AM in C++ Programming

avatar image

JohnMirrah
11 1 1 1

avatar image tai65535 Mar 17 '17 at 02:08 AM

Hello John, I am assuming you have solved this problem? Mine http request for https server works on PC but fails on iOS. Thank you.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question