x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

EpicGamesLauncher (0xc000007b)

I know there are several posts about launcher installation errors with this error code already, but I've tried the various solutions supplied in those threads to no avail. I've tried manually installing directx and then disabling that portion of the installer but I still get the same error when trying to run the launcher. I've also tried replacing the d3dcompiler_43.dll in my system folder. I've used CCcleaner to tidy up the registry and have made sure windows and my nvidia drivers are up to date but still get the same error.

The log says that installation completed successfully, but the installer window closes very abruptly after the directx installation (or around that point when dx installation is disabled). The installer doesn't give me any final options and doesn't create any start menu links, though it does create a desktop shortcut which of course doesn't work.

Attached is my dxdiag.txt and here is a link to my installer log (because it was too big to attach here): https://dl.dropboxusercontent.com/u/6754798/EpicGamesInstallerLog.txt

My system specs are:

Windows 8.1 Pro Intel(R) Core(TM) i7-4770K CPU 24576MB RAM Nvidia GTX780

Product Version: Not Selected
Tags:
dxdiag.txt (95.4 kB)
more ▼

asked May 12 '15 at 01:26 AM in Installation & Setup

avatar image

micahganske
1 2 2 2

avatar image micahganske May 12 '15 at 01:33 AM

Sorry for the multiple posts on the same question. The site kept giving me an error so I didn't think anything had been posted.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

If you are seeing this error then the launcher install completed. This means the installer logs won't be helpful in this case. Usually we need logs from a tool called Dependency Walker to track down the root cause of the problem. You can read more about the process of getting a DW log here(includes some tips on what to look for in your log): https://answers.unrealengine.com/questions/12975/unreal-engine-wont-launch-error-code-0xc000007b.html

If you get stuck, you can post your log and we'll try to help.

more ▼

answered May 12 '15 at 03:19 AM

avatar image

0xDEADBEEF STAFF
1.5k 18 12 47

avatar image micahganske May 12 '15 at 06:01 PM

Excellent! Thank you very much. I did not know about Dependency Walker but what a very useful program! I pinpointed the issue as being MSVCR120.DLL and replaced it with the 64bit version and everything is working now. Thanks for your help!

avatar image Zaneycox May 14 '15 at 11:06 AM

I seem to be having the same issue with the DLL I replaced and and I got the same error

avatar image 0xDEADBEEF STAFF May 14 '15 at 10:21 PM

Zaneycox, perhaps you can start a new thread with your dependency walker logs included.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question