x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

RunUAT.bat Error Unreal engine 4.8 Preview2

Hi, I've been trying to adress exactly what is wrong with my project and why it won't package. It plays just fine in the editor, but i've been trying to package it for a while now, and it's not really working. No matter what it always build fails, and the runUAT.bat error. I'm not sure if it's a corrupted file, or something, I will place the output log from the build because i do not know what the error is.link text

Here is the game that I'm working on and you could help save. http://mfi.re/watch/7tte6j64c2lbvl3/Prroject_Ehanced.mp4

and here is a video of the day night cycle, and whatnot, more outside environment. http://mfi.re/watch/mzv0mrhrds6vw6p/Modular_Map10_MatineeActor_1_30fps_1280x720_02.mp4

I really want to make this game a possibility, but without the ability to cook i simply cannot.

General Information is listed below to help out the process: -The game is done entirely in blueprints -It is using multiplayer. -there is a lot of things the player is doing, and is able to do. (I'm not sure if corrupted code is a thing, but maybe a possibility.) -I have moved my version from 4.7.5 up to 4.8 preview, to try to help solve this and same error. -I have 2 drives, one for storage and one for my registry. My project is located on my storage files. Any more information i will give, just message me, or comment.

here is a quick picture:

Product Version: Not Selected
Tags:
myproject2.log (4.6 MB)
more ▼

asked May 13 '15 at 11:58 AM in Packaging & Deployment

avatar image

caelanim8ter
48 8 15 16

avatar image Ravlek STAFF May 13 '15 at 07:03 PM

It looks like you are trying to package for the Desktop platform. Try packaging for just Windows and see if that works correctly. The Desktop platform is relatively new and may still have some bugs with it in the 4.8 Preview 2 release.

-Pete

avatar image caelanim8ter May 13 '15 at 08:04 PM

I want to thank you for your reply, i didn't think a staff would be caring enough to read through a bunch of stuff just to help out, so thank you. however I have tryed to package this back on the previouse version 4.7.5 on the windows, and still not able to package, runuat.bat error. Any other solution/suggestions?

avatar image Ravlek STAFF May 13 '15 at 08:10 PM

Could you post the log from the 4.7.5 run? It might be a different error than the desktop platform error in 4.8.

-Pete

avatar image caelanim8ter May 13 '15 at 08:38 PM

link text

link text

There is a cook. and uat log, I'm pretty sure only the cook is needed. I just cooked it btw.

cook.txt (1.1 MB)
uat_log.txt (1.2 MB)
avatar image Ravlek STAFF May 13 '15 at 08:50 PM

This looks like it might be a crash bug that we just haven't encountered yet. Did you attach a text render component to the scene somewhere? If so, can you remove it and see if it cooks?

-Pete

avatar image caelanim8ter May 13 '15 at 08:54 PM

2:Do you know if Is the text render component be in an asset?

avatar image caelanim8ter May 13 '15 at 08:55 PM

Because i don't think i see it anywhere in the levels, but it's possible it would be in an asset.

avatar image caelanim8ter May 13 '15 at 09:16 PM

Okay update, I searched around, for a text component, couldn't find any, but looked around my assets that would have any text components and deleted them completey, I've just attempted packaged, and still not working, What i'm doing now is packaging the game by deleting the main map, to see if it will work: modularmap10, the other map i have is a menu map. was there any other suggestions to follow? Other than the text components, because i don't believe thats the problem

avatar image caelanim8ter May 13 '15 at 09:20 PM

here is the updated cook without the main menu map, as deleting the text component didn't work, and deleted the map also:

link text

cook.txt (2.3 MB)
avatar image Ravlek STAFF May 18 '15 at 01:50 PM

[2015.05.13-21.10.17:178][ 0]LogBlueprint:Error: [compiler] Error This blueprint (self) is not a TextRenderComponent, therefore ' Target ' must have a connection. [2015.05.13-21.10.17:573][ 0]LogBlueprint:Warning: [compiler] Warning [0037.56] Compile of kaylin failed. 1 Fatal Issue(s) 0 Warning(s) [in 1,144 ms]

Looks like this blueprint is failing to compile and it does seem to want to reference a TextRenderComponent, so it probably is the source of the original issue as well.

-Pete

avatar image caelanim8ter May 24 '15 at 08:06 PM

That was the problem, a corrupted kaylin (Its my player blueprint). Thank you so much for helping solve this issue!

avatar image Samantha Sutton ♦♦ STAFF May 26 '15 at 08:47 PM

Hey Caelanim8ter,

I'm glad that Pete was able to resolve your issue. If you have any further questions, please reply back or create a new post on AnswerHub and we'll assist you further.

Have a great day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Caelanim8ter,

I have not heard from you in quite some time. At this time, I must close your thread out as being marked 'answered'. However, if you have any further questions or concerns regarding this specific topic, do not hesitate to reply back.

Thank you!

more ▼

answered May 22 '15 at 02:15 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question