x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Constant crashes in Blueprints

I cannot do anything other than looking at Blueprints. As soon as I try to display class settings, class defaults, or if I create a variable (directly or via "Promote to a variable"), it crashes. Everytime. I tried new projects (C++, Blueprint), and projects converted from 4.7.5. Same thing.

It's such a major bug (and yes, I rebooted my computer). Am I the only one with this issue?

I get the following error (full log attached): Unknown exception - code 00000001 (first/second chance not available)

"Assertion failed: IsValid() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Core\Public\Templates\SharedPointe

Product Version: UE 4.8 Preview
Tags:
crashlog.txt (5.3 kB)
more ▼

asked May 13 '15 at 02:42 PM in Blueprint Scripting

avatar image

morph208
81 5 7 21

avatar image Adam Davis STAFF May 13 '15 at 03:04 PM

Hi morph208,

I haven't been able to reproduce this on my end. Can you upload the full crashlogs (the file you uploaded is the callstack)? They are located at \Unreal Projects\PROJECTNAME\saved\logs. The steps I took to try and reproduce this were:

  1. Open project (any)

  2. Create new actor BP

  3. Go into event graph

  4. Right click begin overlap event "Other Actor" pin>Promote to variable

  5. Open Settings

  6. Open Defaults

  7. Change settings in either settings or defaults

  8. Compile

  9. Attempt steps 3-8 with Character BP as well.

Are there any steps you are taking that I am not? I'm happy to continue attempting to reproduce this error so we can get it quickly resolved.

avatar image morph208 May 13 '15 at 05:21 PM

Thanks Adam. I'm aware that it must be something specific with my config. I asked a colleague and she does not have any issue on her side. But it's reproducible, even after a reboot. If I create a new Blueprint blank project, right click in the content browser, new Blueprint class, I inherit from Actor, then in the event graph of this class, if I click on "add new variable", it crashes. And I still have no issue whatsoever with 4.7.5.

I removed the installation of 4.8 and I'm currently doing another install. I will let you know.

In the meantime, I attached the full log you requested. link text

democolibri.log (49.0 kB)
avatar image morph208 May 13 '15 at 06:03 PM

I re-installed 4.8 but still the same thing. I followed the steps you described Adam, step 4 crashes for me.

This is the full log of the brand new blank Blueprint project I created after a fresh install of 4.8 P2 after the crash I got at step 4:

link text

myproject.log (24.6 kB)
avatar image Adam Davis STAFF May 13 '15 at 06:26 PM

Can you post your dxdiag? While I highly doubt it it may be hardware specific so I'd like to rule this out as a potential option.

avatar image morph208 May 13 '15 at 07:33 PM

Sure. Here it is.

link text

dxdiag.txt (26.8 kB)
avatar image Adam Davis STAFF May 13 '15 at 07:56 PM

Try updating your video card drivers to see if that helps any. I'm not certain it will help but it certainly can't hurt to try! I'll keep trying to reproduce on my end.

avatar image morph208 May 13 '15 at 08:33 PM

I updated my graphics driver to the latest (NVIDIA 350.12). Still the same problem. I may have a somewhat particular configuration, for instance I don't have sound (my computer does not have any audio card). And I have the latest Oculus runtime (0.5.0.1) installed. I don't know why it would affect the Blueprint editor but... I thought I would mention it in case you guys made changes related to audio or/and Oculus in 4.8. Besides that, I don't know what can I try... It's obviously a blocker, I cannot use 4.8 preview 2 (the first preview was fine). Thanks for trying Adam. I will keep doing tests on my side.

avatar image Adam Davis STAFF May 14 '15 at 03:36 PM

We tried running this test on one of the pc's here that has Oculus set up with the .5 SDK installed and did not reproduce the crash. Is there anything else specific to your pc that could be causing this error? Do you have permissions set up for your firewall? I honestly can't think of anything else that would cause this kind of crash on one pc but no others, it's a bit bizarre.

avatar image morph208 May 14 '15 at 03:41 PM

I agree, it's bizarre. It still works fine with 4.7.5 and 4.8 preview 1 worked great too. I just finished compiling the editor from source to get a closer look.

avatar image morph208 May 14 '15 at 05:19 PM

I tested with the editor compiled from source (tagged 4.8 taken yesterday at revision 651c353759588a46d8b25cd815a12ddcf3ffbeb8) and I have no problem! So I don't know what to think of it. Technically it's not the same project though since it forced me to make a copy of it (as it detected it was not the same version, but that might be normal between a binary version and the one compiled from source). I hope preview 3 will make this things disappear.

avatar image Adam Davis STAFF May 14 '15 at 06:10 PM

That is good that the github build doesn't crash on you. For now, lets hold off until Preview 3 to see if you get the same errors there. I'll leave this question open until then so we can test and see if you have any further errors.

avatar image morph208 May 14 '15 at 07:15 PM

Thank you so much for trying Adam. Since I'm curious I've downloaded the preview 2 from github, compiled it, and tried it. It detected that the project was not the same version (which I found weird since they are actually the same), I converted my project in place, and I have no problem! So there's something weird about the binary preview 2 I have (even though I tried to re-install it already). Very weird. It's the type of problem where you never know what it is. Anyway, it will probably be fixed by itself with preview 3 in a few days. In the meantime I will use the preview 2 I compiled from source.

Just one question: why did it detect it was a different version? If I commit some changes done with my preview 2 from source, will my colleagues have problems with my files using the binary preview 2??

avatar image spyro May 19 '15 at 08:49 PM

I can confirm this. Got crashes every 1-2 minutes or so after converting a project from 4.7.6 to 4.8 Preview 2.

avatar image morph208 May 21 '15 at 12:33 PM

Yes, that's the thing. I made the test on a new computer with 4.8 preview 3. At first, it worked fine. But it stopped working after a while. Not sure why or how it occured. Did I have a limited number of click, an amount of time or did I do anything in between that triggered the bug, I don't know.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

As long as they are both preview 2 they should be fine to transfer between.

more ▼

answered May 19 '15 at 03:50 PM

avatar image morph208 May 19 '15 at 05:48 PM

I tried Preview 3 and it still the same issue for me. Here what I did:

  • Uninstall preview 2

  • Install preview 3

  • Create a new Blueprint project

  • Right-click in content browser, new Blueprint class inhering from Actor

  • Trying to open 'Class settings' tab is enough to crash

I attached the full log.

mytest.log (25.4 kB)
avatar image Adam Davis STAFF May 19 '15 at 06:44 PM

Hi morpph208,

Opening the class defaults/settings causing a crash is a known issue and has been reported under UE-15837.

avatar image morph208 May 19 '15 at 07:17 PM

Ah ok. Good to know. It means that it will be fixed at some point. Any hint on what would be the cause? Do I have a workaround in the meantime?

avatar image Adam Davis STAFF May 19 '15 at 07:29 PM

Unfortunately no, we found it maybe ten minutes before I responded here. However, it is a blocker so once it gets assessed it will probably be quickly fixed so developers can continue working.

avatar image morph208 May 21 '15 at 09:21 PM

Since I cannot open the 'Class settings' tab from inside the editor without a crash, is there any way to reset the default layout of the tabs? I believe that if the 'Class settings' tab is already opened when the editor opens, it works fine. But if I close the tab and try to open it again it, it crashes. Since I closed it and the editor saved that configuration, I'm stuck. But if there was a way to reset this settings and start the editor with the 'Class settings' opened, I think I could work.

avatar image Adam Davis STAFF May 21 '15 at 09:34 PM

To do this go to Window>Reset Layout. It should restart the project and reset the layouts in that time.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question