x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Plugin linking resource error

Hello, we keep getting this error when building our Plugin on either 4.6 or 4.7. It is an editor only plugin. Additionally, this error does not happen when we build on OS X.

 >  Performing 3 actions (4 in parallel)
 >  [1/3] Resource ModuleVersionResource.rc.inl
 >  [2/3] Resource PCLaunch.rc
 >EXEC : fatal error RC1107: invalid usage; use RC /? for Help
 >  
 >EXEC : fatal error RC1107: invalid usage; use RC /? for Help
 >  

Could anyone please shed some light on what's going on? Not exactly sure where to start debugging this.

ModuleVersionResource.rc.inl looks fine.

If i open PCLaunch.rc (Engine\Source\Runtime\Launch\Resources\Windows) in Visual Studio, I get 'fatal error RC1015: cannot open include file 'CoreMiscDefines.h'.

Any help is appreciated, thanks.

Product Version: UE 4.7
Tags:
more ▼

asked May 13 '15 at 06:47 PM in C++ Programming

avatar image

ttvd
333 20 25 34

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

The question has been closed Nov 10 '15 at 04:23 PM by ttvd for the following reason:

Problem is not reproducible or outdated


1 answer: sort voted first

Hello, ttvd

Sorry to hear about your issue.

To fix it, please try the following:

1) In Visual Studio, go to Project - Properties - Configuration Properties - VC++ Directories.

2) In Include Directories, remove the trailing backslash from the last path (if it is already there). In case there is none, add one.

3) Rebuild the project.

Hope this helped!

Good luck!

more ▼

answered May 14 '15 at 09:36 AM

avatar image

Andrii Melnyk
1.8k 60 19 112

avatar image ttvd May 14 '15 at 08:20 PM

Hello! That seems to have worked, but is still failing once in a while. Is there a better solution to this problem? Occasionally, after regenerating solution I can't seem to bypass this issue at all, even if I follow your instructions.

avatar image ttvd May 15 '15 at 10:12 PM

Hello. I have solved the issue. This was caused by adding a definition in build.cs file which contained double quotes. (Definitions.Add("Foo=\"bar\"")).

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question