x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE4 Editor for Linux build fail

I'm running Ubuntu Linux 15.04, EDIT: I run clang 3.5.2, and https://wiki.unrealengine.com/Linux_Known_Issues#UE4Editor says that is it a known issue but provides no information on how to troubleshoot it. and I was following the linux compilation instructions. I started building the editor as in https://wiki.unrealengine.com/Building_On_Linux#The_Editor But, the build failed and I got the following error.

 bash "/home/raghuallthetime/UnrealEngine"/Engine/Build/BatchFiles/Linux/Build.sh UE4Editor Linux Development  
 Building UE4Editor...
 Using clang version '3.5.2' (string), 3 (major), 5 (minor), 2 (patch)
 /bin/sh  -c '/bin/sh "/home/raghuallthetime/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UE4Editor/Development/FixDependencies.sh" && touch "/home/raghuallthetime/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UE4Editor/Development/UE4Editor.link"'
 Performing 146 actions (2 in parallel)
 [1/146] Compile Module.UnrealEd.16_of_18.cpp
 In file included from /home/raghuallthetime/UnrealEngine/Engine/Intermediate/Build/Linux/x86_64-unknown-linux-gnu/UE4Editor/Development/UnrealEd/Module.UnrealEd.16_of_18.cpp:20:
 /home/raghuallthetime/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/Settings/SettingsClasses.cpp:359:25: error: equality comparison result unused [-Werror,-Wunused-comparison]
                 BuildGameBeforeLaunch == EPlayOnBuildMode::PlayOnBuild_Never;
                 ~~~~~~~~~~~~~~~~~~~~~~^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 /home/raghuallthetime/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/Settings/SettingsClasses.cpp:359:25: note: use '=' to turn this equality comparison into an assignment
                 BuildGameBeforeLaunch == EPlayOnBuildMode::PlayOnBuild_Never;
                                       ^~
                                       =
 1 error generated.
 -------- End Detailed Actions Stats -----------------------------------------------------------
 ERROR: UBT ERROR: Failed to produce item: /home/raghuallthetime/UnrealEngine/Engine/Binaries/Linux/libUE4Editor-UnrealEd.so
 Total build time: 31.89 seconds
 Makefile:171: recipe for target 'UE4Editor' failed
 make: *** [UE4Editor] Error 5

Please Help!

Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 14 '15 at 05:11 AM in Installation & Setup

avatar image

RaghuAllTheTime
1 1 2 3

avatar image Doug E ♦♦ STAFF May 18 '15 at 03:12 PM

Hey RaghuAllTheTime-

Were you building the 4.8 branch from github or the 4.8Preview tag? If you were building from the tag, were you building preview 1 or preview 2? At what point in the build process did the failure occur (running Setup.sh, running GenerateProjectFiles.sh, etc.)? Do you have the same error when building other versions of the engine?

Cheers

Doug Wilson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey RaghuAllTheTime-

We've not heard back from you in a few days. I am marking this post as resolved for tracking purposes. Let us know if you're still having problems with installing the engine on your machine and we will continue to investigate.

Cheers

Doug Wilson

more ▼

answered May 26 '15 at 04:25 PM

avatar image RaghuAllTheTime May 27 '15 at 11:18 AM

Ok I tried again, but I didn't clone. I downloaded the zip file. The build worked, but UE4Editor crashed. The thing was that, I had an unsupported graphics card. Sorry for wasting your time!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question