x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

4.7.6 Crash when replicating blueprints

After dragging a cube (was happening with my own static mesh objects too) onto the scene. I used the Blueprint/Add Script button (as shown in image 1) to create a Cube_Blueprint. I changed the settings of the Cube_Blueprint to Replicates (as shown in image 2). I went into the Level Blueprint (happens from any blueprint from what I have seen) and set it to On Begin Play, spawn actor (as shown in image 3).

If I press play, with just 1 player, it works fine. But if I add a second player. On play, the client (not the server) fails to load, and Unreal crashes. I also tested this where I didn't set the blueprint to replicates, and instead set it to replicate when I pressed a key during play. This also caused the engine to crash.

I found that if the object I am setting to replicate is already in the scene, it won't crash, only for objects that are spawned.

If I create the blueprint not using that button, and instead, right click, create blueprint, and manually set the staticmeshcomponent to the Cube mesh it all works perfectly fine. It only seems to be an issue when using that button.

Hopefully this is enough info for you guys to reproduce this and fix it (if you don't already know about it and have fixed it for 4.8, but I couldn't find any info on it when I searched for the problem)

alt text

alt text

alt text

Product Version: UE 4.7
Tags:
bug1.png (555.8 kB)
bug2.png (8.6 kB)
bug3.png (72.0 kB)
bug3.png (72.0 kB)
more ▼

asked May 14 '15 at 11:25 AM in Bug Reports

avatar image

Faelinor
1 1 2

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Faelinor,

Thanks for the detailed report! I was able to reproduce this crash in 4.7.6 as well as our internal builds, so I created a bug report for the issue (UE-15637). I'll post here when I see any update on it. Thanks again!

more ▼

answered May 14 '15 at 10:11 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question