x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Player start isn't possessing player controller automatically

What the title says. It was working fine at one point the all of a sudden it doesn't and i have to press f8?

Product Version: UE 4.7
Tags:
more ▼

asked May 14 '15 at 08:16 PM in Using UE4

avatar image

call95
54 11 15 22

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi call95,

Have you changed the Game Mode at all? To change it, you could either change it in the World Settings or by going to Edit -> Project Settings -> Map and Modes -> Default Game Mode. Be sure that the Player Controller you're using is set as the default and it should possess it automatically.

Hope this helps, if not, please feel free to let me know.

Matthew Clark

more ▼

answered May 14 '15 at 09:00 PM

avatar image Matthew J May 20 '15 at 06:45 PM

Have you found the solution to your issue? If you still require assistance, please let me know and I'll be happy to help.

avatar image Matthew J May 26 '15 at 02:32 PM

Hi call95

We haven't heard from you in a while. In the meantime, I'll be marking this issue as resolved. Please feel free to comment if you require more assistance and the question will reopen.

avatar image nazu2d1j Apr 20 '17 at 10:38 PM

i have changed my game mode but still i have to press f8 for the player to start

avatar image Miroac Apr 20 '17 at 10:49 PM

Ok so it could be either that you are actually starting in simulation mode instead of play in viewport, or you just need to double check you game mode settings.

My guess is that you are simulating which can be changed like so:

alt text

For the game mode, make sure that the game mode is being set in the world settings like so:

alt text

Also that in the game mode blueprint you have set the player pawn and the player controller (if you made a controller and didn't do all your logic in your pawn):

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question