x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Project crashes on load after saving

I have been working on a project for some time, it has been open the past 3 days, last night I closed it as the RAM was up to a 3GB after those few days. During those few days, the only things I really edited were 1 BP and few float curves. Today I tried to open it, and got an error message:

 MachineId:9C27B57442A82B2F1D1B4798CA6104C2
 EpicAccountId:08d5f100ae2d4a059f5498c9c4561829
 
 Unknown exception - code 00000001 (first/second chance not available)
 
 Assertion failed: Component [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Engine\Private\Blueprint.cpp] [Line: 1122] 
 
 KERNELBASE + 35740 bytes
 UE4Editor_Core!FOutputDeviceWindowsError::Serialize() + 292 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95]
 UE4Editor_Core!FOutputDevice::Logf__VA() + 248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:144]
 UE4Editor_Core!FDebug::AssertFailed() + 1079 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\misc\outputdevice.cpp:224]
 UE4Editor_Engine!UBlueprint::ChangeOwnerOfTemplates() + 426 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\blueprint.cpp:1123]
 UE4Editor_Engine!UBlueprint::PostLoadSubobjects() + 23 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\engine\private\blueprint.cpp:1222]
 UE4Editor_CoreUObject!UObject::ConditionalPostLoadSubobjects() + 61 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\obj.cpp:717]
 UE4Editor_CoreUObject!UObject::ConditionalPostLoad() + 446 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\obj.cpp:625]
 UE4Editor_CoreUObject!EndLoad() + 1724 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:1126]
 UE4Editor_CoreUObject!LoadPackageInternal() + 2248 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\coreuobject\private\uobject\uobjectglobals.cpp:906]
 UE4Editor_UnrealEd!UEditorEngine::Map_Load() + 5034 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\editorserver.cpp:2245]
 UE4Editor_UnrealEd!UEditorEngine::HandleMapCommand() + 349 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\editorserver.cpp:5680]
 UE4Editor_UnrealEd!UEditorEngine::Exec() + 797 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\editorserver.cpp:5180]
 UE4Editor_UnrealEd!UUnrealEdEngine::Exec() + 273 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealedsrv.cpp:742]
 UE4Editor_UnrealEd!FEditorFileUtils::LoadMap() + 789 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\filehelpers.cpp:1910]
 UE4Editor_UnrealEd!FEditorFileUtils::LoadDefaultMapAtStartup() + 216 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\filehelpers.cpp:3070]
 UE4Editor_UnrealEd!FUnrealEdMisc::OnInit() + 2263 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealedmisc.cpp:299]
 UE4Editor_UnrealEd!EditorInit() + 3254 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\editor\unrealed\private\unrealed.cpp:86]
 UE4Editor!GuardedMain() + 926 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\launch.cpp:133]
 UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
 UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]


I've restarted the launcher, restarted my PC, tried launching project from root folder, and none of this has worked. Any suggestions? Edit #1: It crashes at 94-95% loading, and my RAM usage is around 200MB, CPU is 5-15.

Edit #2: I read some other posts, and I deleted my content folder, it then worked to open my project. After that I re-pasted the content folder, and deleted everything except my main BP folder. It also worked again, so apparently some other asset it causing the problem, but now I have another very bad problem, clicking or right clicking on my MOST IMPORTANT blueprint in my project will cause the editor to crash. How can I get my BP back? It has lots of math and algorithms, so I can't simply remake it.

Edit #3: I've figured out that all of the autosaves before 2 hours after I saved and quit work, and unfortunately all of the stuff I got done happened during the 2 hours. Still need a way to get my most recent BP back.

Product Version: UE 4.7
Tags:
more ▼

asked May 15 '15 at 12:34 PM in Bug Reports

avatar image

Jamendxman3
638 15 21 63

avatar image Adam Davis STAFF May 15 '15 at 02:36 PM

Can you post a copy of your crash logs here? You can find those at \Unreal Projects\PROJECTNAME\saved\logs\

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Jamendxman3,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

more ▼

answered May 20 '15 at 08:15 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question