x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Help - UE 4 4.6.1 or 4.7.6

Hello,

I am having trouble deciding which version of UE4 to use. First of all, here are my system specifications:

  • Processor: AMD FX-8350

  • Motherboard: ASUS Sabertooth 990FX/GEN3 R2.0

  • Memory: GSkill Ripjaws 32 GB total

  • GPU: AMD Radeon HD 6970 with 2GB GDDR3 VRAM

  • Storage: Standard Seagate Barracuda HDDs defragmented regularly

System is kept in top state at all times and all drivers are updated regularly.

I was happily using Unreal Engine version 4.6.1 until recently when it started to crash when any asset is copied or moved in the content browser in any project. Here's a couple of crash reports:

 Assertion failed: !Obj->HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad|RF_ClassDefaultObject) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 1744] 
 Attempting to replace an object that hasn't been fully loaded: BlueprintGeneratedClass /Game/Character/AIGuard2/AIGuardBP.AIGuardBP_C
 
 
 KERNELBASE.dll!UnknownFunction (0x000007fefce1aaad) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedceb2f7d) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedcd460f8) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedcd29192) + 0 bytes [UnknownFile:0]
 UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fede77ef88) + 0 bytes [UnknownFile:0]
 UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fede77fcf9) + 0 bytes [UnknownFile:0]
 UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fedb1885eb) + 0 bytes [UnknownFile:0]
 UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fede780e22) + 0 bytes [UnknownFile:0]
 UE4Editor-CoreUObject.dll!UnknownFunction (0x000007fede780262) + 0 bytes [UnknownFile:0]
 UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fedabc5c08) + 0 bytes [UnknownFile:0]
 UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fedabc491c) + 0 bytes [UnknownFile:0]
 UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed028ec40) + 0 bytes [UnknownFile:0]
 UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed02c8800) + 0 bytes [UnknownFile:0]
 UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed02b95cc) + 0 bytes [UnknownFile:0]
 UE4Editor-ContentBrowser.dll!UnknownFunction (0x000007fed02c3a06) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbdf68a3) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbdfb058) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbd7b747) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbd7d299) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbdde419) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbe84b9a) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbeb0a73) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbce97bc) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbca7347) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbd4b2e0) + 0 bytes [UnknownFile:0]
 UE4Editor-Slate.dll!UnknownFunction (0x000007fedbd3c226) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedce1e9e9) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedce0a1fb) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedce1fbbb) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedce06cf2) + 0 bytes [UnknownFile:0]
 USER32.dll!UnknownFunction (0x0000000076e19bd1) + 0 bytes [UnknownFile:0]
 USER32.dll!UnknownFunction (0x0000000076e198da) + 0 bytes [UnknownFile:0]
 UE4Editor-Core.dll!UnknownFunction (0x000007fedce20076) + 0 bytes [UnknownFile:0]
 UE4Editor.exe!FEngineLoop::Tick() (0x000000013f6bcbda) + 8 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2193]
 UE4Editor.exe!GuardedMain() (0x000000013f6b089f) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]
 UE4Editor.exe!GuardedMainWrapper() (0x000000013f6b090a) + 5 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor.exe!WinMain() (0x000000013f6be3d9) + 17 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
 UE4Editor.exe!__tmainCRTStartup() (0x000000013f6bf319) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]
 kernel32.dll!UnknownFunction (0x0000000076f159cd) + 0 bytes [UnknownFile:0]
 ntdll.dll!UnknownFunction (0x000000007704b981) + 0 bytes [UnknownFile:0]
 ntdll.dll!UnknownFunction (0x000000007704b981) + 0 bytes [UnknownFile:0]
 
 
 MachineId:CEEA1CAF463420F100BBD2A360EAA643
 EpicAccountId:a73c221e21314ee88a1cc7e25ad9acd6
 
 Unknown exception - code 00000001 (first/second chance not available)
 
 Assertion failed: !Obj->HasAnyFlags(RF_NeedLoad|RF_NeedPostLoad|RF_ClassDefaultObject) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\CoreUObject\Private\UObject\UObjectGlobals.cpp] [Line: 1744] 
 Attempting to rep
 
 KERNELBASE + 109229 bytes
 UE4Editor_Core + 3092349 bytes
 UE4Editor_Core + 1597688 bytes
 UE4Editor_Core + 1479058 bytes
 UE4Editor_CoreUObject + 1568648 bytes
 UE4Editor_CoreUObject + 1572089 bytes
 UE4Editor_UnrealEd + 9602539 bytes
 UE4Editor_CoreUObject + 1576482 bytes
 UE4Editor_CoreUObject + 1573474 bytes
 UE4Editor_UnrealEd + 3562504 bytes
 UE4Editor_UnrealEd + 3557660 bytes
 UE4Editor_ContentBrowser + 1174592 bytes
 UE4Editor_ContentBrowser + 1411072 bytes
 UE4Editor_ContentBrowser + 1349068 bytes
 UE4Editor_ContentBrowser + 1391110 bytes
 UE4Editor_Slate + 1534115 bytes
 UE4Editor_Slate + 1552472 bytes
 UE4Editor_Slate + 1029959 bytes
 UE4Editor_Slate + 1036953 bytes
 UE4Editor_Slate + 1434649 bytes
 UE4Editor_Slate + 2116506 bytes
 UE4Editor_Slate + 2296435 bytes
 UE4Editor_Slate + 432060 bytes
 UE4Editor_Slate + 160583 bytes
 UE4Editor_Slate + 832224 bytes
 UE4Editor_Slate + 770598 bytes
 UE4Editor_Core + 2484713 bytes
 UE4Editor_Core + 2400763 bytes
 UE4Editor_Core + 2489275 bytes
 UE4Editor_Core + 2387186 bytes
 user32 + 105425 bytes
 user32 + 104666 bytes
 UE4Editor_Core + 2490486 bytes
 UE4Editor!FEngineLoop::Tick() + 3434 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2193]
 UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]
 UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]
 UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]
 UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]


So I decided to try the new 4.7 version of UE4. The scene I am using is Urban City from the market place. I optimised it by heavily reducing the number of lights, foliage, reflection spheres and props. I tried contacting the content provider for that but either there is no response or the emails bounce; the thread is not updated as well. Now here's the problem. That scene when opened in 4.6.1 is running super smooth. System settings have been auto-detected by Unreal, set to High (Not Epic). Here are the stats:

4.6.1 Stats

That same scene when opened in 4.7+ gives super reduced performance. Also note the overall gamma/brightness change. No settings have been changed. The scene has been opened in 4.7.6 as a copy. Here are the stats:

4.7.6

I do not know what is happening, nor can I afford the time to troubleshoot the problem on my own. I'd rather use 4.6.1 because it is working properly rather than use a future version with extra features but reduced performance.

Also, overlapping dynamic lights create artifacts. I tried to read the documentation on removing lighting artifacts and cascaded shadow maps / Shadow Bias / Shadow Filter but I am finding it hard to understand and experiment. Surprisingly the dynamic shadows were working properly in 4.7 without any change in light settings (no artefacts in 4.7 prior to 4.7.6). They came back in 4.7.6. AMD drivers were updated to stable release beforehand and remained same during all experiments. I fail to comprehend different scene renders at different times with the same settings on same hardware using the same lighting solution. Here are the screenshots (wonder why camera actor has disappeared in 4.7.6?):

4.6.1 Dynamic Light Artifacts

4.7.6 Dynamic Light Artifacts

I don't quite understand why the dynamic shadows are faint in 4.7.6. Perhaps because of extra unintentional brightness / gamma, but they are still there.

If someone can help me sort out the content browser crash and overlapping dynamic light artefacts in 4.6.1 I'd happily continue using that and get more work done. I have already invested enough time to have the scene working smoothly in this version. I'd really hate to go through the performance troubleshooting and lighting process again in 4.7.6+, but I am willing to hear any ad-hoc solutions.

What I have tried till now:

1] Verify installations of 4.6.1 and 4.7.6 both; 2] Restarted the system and checked again, built lighting solution again (for a few static lights other than the dynamic ones). I thought the sleep and wake process of my computer might be interfering; 3] Tried a lot of troubleshooting to the extent of my knowledge and understanding in lighting, rendering, using statistics, Unreal Engine, Windows 7 64-bit, IT and computers in general;

I finally realised I need help. If someone can find out what's going wrong or offers a solution, I'd be much grateful.

Thanks in advance,

Markus.

Product Version: UE 4.7
Tags:
more ▼

asked May 15 '15 at 09:05 AM in Using UE4

avatar image

Markus Maximus
41 3 10 9

avatar image Markus Maximus May 15 '15 at 01:29 PM

Edit: I solved the artifact problem finally after months! It seems we have to be dot accurate about placing lights anywhere and ensure they do not intersect with any geometry. Incidentally, our content provider had not taken those precautions. Anyway, one problem solved. Now if anyone can help with the content copy crash issue...

(comments are locked)
10|2000 characters needed characters left

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question