x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix Mixamo characters' blurry animations?

I have created an endless runner game using the tutorial on Youtube, and the default third person character works fine, but after changing the mesh and the animation blueprint to Mixamo Adam, the character's running animation appears blurry. The arms appear especially blurry. How can this be resolved?

Product Version: UE 4.7
Tags:
more ▼

asked May 15 '15 at 11:55 PM in Rendering

avatar image

Chinooks
38 5 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You might need to change Motion Blur values of your Global Post Process. Reduce them to 0 if you dont want blur.

more ▼

answered May 16 '15 at 04:55 AM

avatar image

Achilleon
782 38 34 70

avatar image Chinooks May 16 '15 at 05:39 AM

Thanks for the answer. I've looked into reducing motion blur but there is no global post process actor in my level. Do I have to create a post process volume and place it into my level to edit the motion blur?

avatar image Achilleon May 16 '15 at 06:05 AM

Exactly. Just add a Post Process into your scene, from its properties tick "Global" and reduce the amount of Motion Blur in it.

Also if I dont remember wrong, you can toggle Motion Blur completely off and on from Project Settings -> Rendering menu.

avatar image Chinooks May 16 '15 at 06:35 AM

I've tried doing both things you suggested but have had no luck. I also found a skeletal mesh property called "per bone motion blur" that I unticked. Still no luck. When my character moves, an outline of where he was still exists for a short amount of time. Could this be caused by something other than motion blur?

avatar image Chinooks May 16 '15 at 06:50 AM

Just figured out a solution. Changing the ant-aliasing from temporalAA to FXAA or none rmoved the blur. However the rest of the game does not look as nice. Is there a way to apply a certain kind of anti aliasing to only one object?

avatar image Achilleon May 16 '15 at 07:03 AM

Can you actually show a screen shot so we can see what kind of motion blur it is? I may not be able to help, but someone who is better at rendering surely can. :)

avatar image Chinooks May 16 '15 at 07:15 AM

alt text

alt text

This is the difference between fxaa and temporalAA. Both have motion blur disabled in project settings. Thanks for all the help.

with fxaa.png (795.2 kB)
with temporalaa.png (795.9 kB)
avatar image Chinooks May 16 '15 at 06:21 PM

To change the AA on one actor, create a post process volume within the blue print and set the AA to whatever you want.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question