x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Is the Create Widget node replaced by a Construct node?

Hi, I'm using a couple of widgets in my game to display and change between the different HUDs. So I've been using the 'Create Widget' node to create and store them at level start. I was trying to link a widget class reference variable to the create widget node today and it got converted to a 'Construct' node. Ever since then, I can only use the Construct node when I try to add Create Widget. Has the Create Widget node been officially replaced by this 'Construct' node?

Product Version: UE 4.7
Tags:
more ▼

asked May 16 '15 at 07:05 AM in Blueprint Scripting

avatar image

Stormrage256
1k 83 75 118

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Mate

Create User widget still there, But says construct when nothing attached and create after attached.

If you search it is create widget, then turns to this

alt text

Then turns to this after

alt text

Narg

capture.jpg (24.2 kB)
capture.jpg (22.8 kB)
more ▼

answered May 16 '15 at 03:27 PM

avatar image

Narghile
1.7k 74 38 110

avatar image Stormrage256 May 16 '15 at 03:31 PM

Hey Narghile, yea it's been showing 'Create Widget' for me until now. Or atleast I haven't noticed it staying as contruct. But today, I tried connecting a variable that holds a reference to a widget class and it just remained as a construct node. I hadn't tried connecting a class to the node before, so I don't know if it's always been like this.

avatar image Stormrage256 May 16 '15 at 03:34 PM

Here's a screenshot:

WidgetConstruct

widgetconstruct.jpg (108.3 kB)
avatar image Narghile May 16 '15 at 03:40 PM

Ok, Never used a VAR before, just used the drop box.

Mine stays as Construct when I use a VAR as well. But I have been on 4.7.6 for a while now, so must of been like that for a little while would be my guess. Have you done any updates recently?

alt text

Narg

capture.jpg (19.1 kB)
avatar image Stormrage256 May 16 '15 at 04:52 PM

Cool, I just wanted to make sure that this was part of some recent update and not some freak code incident. I'm using 4.7.6 as well. Thanks for confirming that man.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question