x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Spline mesh not showing in packaged project

I am running my packaged project in 4.7.6 and I'm having an issue with a spline mesh not showing in game.

The meshes aren't showing, I use the spline points for the AI to follow and they still follow that so the spline is there in some capacity.

This is similar to the blueprint spline tutorial by epic but I implemented it within C++

Has anyone had a similar issue?

Thanks

Product Version: UE 4.7
Tags:
more ▼

asked May 17 '15 at 09:49 PM in Packaging & Deployment

avatar image

Matty1209
0 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Matty1209,

Would you be able to test and confirm this issue still occurs in our most recent binary release of the engine (4.9.2)?

If so, would you mind providing some simple steps, screenshots, or any other relevant pieces of information to help us reproduce the issue on our end?

Thank you,

Andrew Hurley

more ▼

answered Oct 11 '15 at 07:59 PM

avatar image bartlomiejwolk May 31 '17 at 06:13 PM

I have similar problem. I created C++ version of the Epic's Blueprint Splines Track project. The generated track is visible in PIE, Simulate and Standalone Game modes (with collisions also working).

alt text

However, after packaging to Win64, the track is no longer there.

alt text

I created a simple test project with launcher ver. UE 4.15.3. Open Level1 to see the track. Package to Win64 to see that the track is not there.

Test project

Someone else created a video with the same issue. Link to the related question: Missing spline mesh component in packaged project

Here's another related question: Spline mesh components generated in "onConstruction" function are not showing up in packaged build.

avatar image AndrewHurley Jun 05 '17 at 07:47 PM

So I just tested a new blueprint based project in 4.15.3, and was able to the spline blueprints when packaged to Win (64-bit).

I noticed yours is a code-based project, and you created your own custom class if I am not mistaken? I packaged your project and indeed was unable to see the spline, but this might be expected since it is your own custom class.

What I did to get the actor to show up, is once you have your final spline shape, you can convert it to a static mesh by using the Merge Actors tool in the right-click menu with the splines selected. Would there be a way for you to reproduce this in a new blank project without any custom classes?

Thank you,

Andrew H.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question