Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No shadow on mesh


After many hours of fun and trouble in UE4 I stumbled across something that was unsolvable for me. Mesh not casting shadow. I have searched all the forums and tried everything but it doesn't help. All spotlights,skylight and directional sunlight are set to stationary, not static. Rendering is set to maximum quality and GI is set to 100 bounces. I have a screenshot attached here so if anyone could help me out I would be thankful!alt text

Product Version: UE 4.7
more ▼

asked May 18 '15 at 10:42 PM in Rendering

avatar image

3 1 2 3

avatar image PixelOmen May 19 '15 at 11:24 AM

The ground, wall, and furniture are all set to static?

avatar image sonicgear May 19 '15 at 11:41 AM

Yes they are

avatar image sonicgear May 19 '15 at 05:18 PM

Any help ?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

did u check the cast shadow on the static mesh?

more ▼

answered May 19 '15 at 08:56 AM

avatar image

23 1 1

avatar image sonicgear May 19 '15 at 11:06 AM

Yep cast shadows checked on static mesh and all lights

avatar image RyanB STAFF May 19 '15 at 10:47 PM

what is the lightmap resolution? There is no direct lighting hitting there so it would only be ambient occlusion that is visible. If you scale that mesh up a bit, eventually you should see a bit of AO in the corners. Have you tried messing with the lightmass settings under world properties? Settings like "fully occluded samples fraction" may help quite a bit. Also maybe crank occlusion power to see. And hiding the entertainment center mesh and taking a screenshot of the ground underneath it will tell the real story of what is going on under there.

As it is, there may be AO underneath that we can't see and theres no res for it to exist at high quality. That said I see a hint of AO behind the monitor. If the resolution is the same on the wall/floor the AO should match.

edit you said 100 bounces, thats probably why. Try reducing it way down. With so many bounces, light will find its way into the corners and it will really negate the AO.

avatar image sonicgear May 20 '15 at 07:22 PM

Updating after a while to let everyone who has this problem that this is the solution! Thank you Ryan, you are my saviour! I actually never realised that GI bounces could affect shadows that much, well Ambient Occlusion simulates shadows at edges and everyone who knows lighting and rendering good would have known this. Poor stupid me!

Thank you once again, I owe you one!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question