x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[4.8p2] SteamVR Plugin Crashes Packaged Build on Launch

Creating a packaged build of my project with SteamVR as the only HMD crashes. If I disable SteamVR and package with just the Oculus plugin as the only HMD there is no crash, so it is definitely specific to the SteamVR plugin. I tried starting the packaged project both with and without the HMD connected/turned on. I'm using a DK2 for testing and everything works great in the editor. I'm building from latest GitHub sources as of 20150518's (yesterday's) latest checkin.

Unfortunately it didn't output a stack trace to the log file but only popped it up as a message. I'm typing up the stack trace from a photo in case that helps, but packaging a project as x64 with SteamVR should be enough to test.

 _delayLoadHelper2()
 _tailMerge_steam_api64_dll()
 FSteamVRHMD::Startup()
 FSteamVRHMD::FSteamVRHMD()
 FSteamVRPlugin::CreateHeadMountedDisplay()
 UEngine::InitializeHMDDevice()
 UEngine::Init()
 UGameEngine::Init()
 FEngineLoop::Init()
 ...
 ...
 ...
Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 19 '15 at 01:44 PM in Bug Reports

avatar image

druidsbane
187 11 21 171

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello hesham,

I was able to reproduce what I believe is the issue that you are seeing. I was not able to get a crash but I was able to get the build to fail by simply packaging with the plugin enabled. I have written up a report ( UE-15827) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

more ▼

answered May 19 '15 at 04:25 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 523

avatar image druidsbane May 19 '15 at 05:15 PM

Did you build from source or use 4.8p2/3? The package failing to build may have been in 4.8p2 as my build was a few commits away from 4.8p3 it may be beyond that and more of an issue starting up. If you attached the pseudo-stack trace above to the issue that might help track it down as well.

Thanks again, It IS a great day!

avatar image Rudy Q ♦♦ STAFF May 20 '15 at 03:02 PM

Hello hesham,

Can you reproduce the crash in a clean project? To answer your question, I tried to reproduce this issue in 4.8 preview 3. If you can reproduce this in a clean project could you provide a detailed list of steps in order to reproduce the crash on our end?

avatar image druidsbane May 20 '15 at 03:07 PM

I can try when I get home tonight. In terms of the packaging error, I did find that the first time I package I might get some symbol error during linking and then a second build would succeed. I'm building from sources as my project needs it so I haven't tried the binary version to see if that makes a difference.

avatar image druidsbane May 22 '15 at 04:47 AM

Looks like this bug is fixed with JJ's latest checking and I can confirm that SteamVR both packages and runs fine for me in a package build.

It was a great day!

avatar image Rudy Q ♦♦ STAFF May 22 '15 at 01:04 PM

Hello hesham,

I am happy to hear that you have got everything working. If the problem returns please feel free to reopen this thread and add any additional information.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question