x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Random bright light at location (0,0,0)

After last lighting build a very bright light appeared at the world location (0,0,0). I have no idea what is causing this, because there is no Actor at this location. I also tried to build only the sublevel in which it occured and didn't change anything. Deleting the Intermediate and Saved folders in the Project and builded agian, no change.

I tried migrating the level into an empty project, which fixed the issue. But I don't have the time to migrate everything into a new project and test everything again, because tomorrow is the last day I am able to build befor I need to hand in my work. alt text

Product Version: UE 4.7
Tags:
bug.png (369.1 kB)
more ▼

asked May 19 '15 at 02:06 PM in Using UE4

avatar image

JakobP
6 1 4

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Jakob,

You mention that you're using levels, is this to build lighting separately? If you have anything in the base level (the persistent level), such as a light, this will be baked and included with the sub level. If you have anything in the persistent it may be worth while to move it to a sub-level and just use the persistent as a foundation rather than something that holds the other levels.

Since you mention you tried this in a another project, you don't necessarily need to migrate everything. You could just select everythign in your level > File > Export all > Choose File Type "Unreal Text (.t3d)".

Then create a new level and then go to File > Import > Select the Unreal Text file you just created.

This will place all the objects in the level where they were before. This may help in seeing if you still get the issue with the light.

Let me know,

Tim

more ▼

answered May 19 '15 at 04:27 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 877

avatar image JakobP May 19 '15 at 04:45 PM

Thank you for the fast reply. I am actually using sublevels for performance reasons. The lighting is in the same sublevel as the static meshes. The problem I am having is that there is a light, so bright that you can't see anything in the room, that is not even supposed to be there, because there is no light actor at this location.

And thank's for the info. I didn't know you could export levels that way.

avatar image Tim Hobson ♦♦ STAFF May 19 '15 at 05:15 PM

If you disable all the lighting (in the details panel uncheck "Affect World") and rebuild lighting. Just Use Preview settings for the build lighting option. This will quickly let us see if the light is still causing the issue.

Then it's a process of going through the ones in that area and seeing what's going on. I'm not sure how many lights you have, but just start with the ones closest to that point and see what happens.

Also, you could try setting the light to movable and see if you're getting any bright lights like that. There may be one with extraordinarily bright settings.

These are some of the areas I would start looking in.

Let me know what you find.

avatar image JakobP May 20 '15 at 05:31 AM

Thank's a lot for your help!

I tried everything from disabling all lights, deleting the lights (in a copy of the project of course) and building every level seperately, but nothing changed the fact that there is this weird light.

But the good thing is that I found an unusual fix for this unusual bug. I just put a hollow BSP at (0,0,0) and the light is concealed in it. To my luck, I don't need to be able to enter this room, so the BSP is not interfering with gameplay.

Thank's, and keep up the good work!

avatar image RotemS Aug 31 '17 at 03:14 PM

Getting the same issue on 4.15.3, can't seem to get rid of what seems like a phantom point light with cast shadows enabled showing up in builds at [0,0,0]. There are absolutely no lights at that location.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question