x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Right-clicking on asset gives error "UE4Editor.exe - No Disk"

Whenever I right-click on an asset that I've purchased from the Asset Store, I'm immediately hit with multiple popup dialogs saying that there's "no disk in the drive". If you look at the asset's Source File Path in its properties window, the drive letter in that path always matches the one in the dialog.

No disk

  • Platform: Windows 8.1 x64

  • Engine: 4.7.6

Product Version: UE 4.7
Tags:
rightclickbug.png (301.1 kB)
more ▼

asked May 20 '15 at 07:51 AM in Bug Reports

avatar image

rohoon
142 16 19 33

avatar image TJ V ♦♦ STAFF May 20 '15 at 01:42 PM

Hi rohoon,

First off, what asset from the Marketplace are you working with?

Also, please post any other info that you can find (Crashlog, Log, & Dmp files).

We have recently encountered a similar issue internally. It seems that his drive was listed as a removable drive and was causing errors with the pathing logic. The workaround that fixed it for him was to rename the drive in question (in your case it's D:) to Z:.

avatar image rohoon May 21 '15 at 12:07 AM

Hi TJ,

I've tried with multiple different packages, and it happens with any asset where the Source File Path contains a drive letter that my computer doesn't have. My guess is that the logic for populating the context menu tries to access the drive in the asset's source path without first checking whether that drive exists.

There's really no other info I can provide that would really help here. The output log doesn't print anything when this issue occurs.

Aside from the fact that I don't really want to rename my drives, I don't think that workaround really applies in this case - the issue is that the drive doesn't exist at all, not that there's a removable drive taking up that slot.

avatar image TJ V ♦♦ STAFF Jun 01 '15 at 06:14 PM

Hi rohoon,

I'm sorry that it's been a few days. Have you had any luck fixing this issue since we last spoke?

avatar image rohoon Jun 03 '15 at 07:33 AM

Hi TJ,

Like I said, it doesn't look like something that I can easily fix without having to map dummy drives, which I don't really want to do.

I was really just submitting this bug report in the hope that it would be flagged as a bug.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I just wanted to give you an update.

It took a bit of tracking down but I found the report for when we experienced this bug internally. It was fixed and I believe it made it into 4.8. If you have time, please give 4.8 Preview 4 a try and let me know if you still experience the issue there. The official 4.8 release should be right around the corner.

Cheers,

TJ

more ▼

answered Jun 04 '15 at 01:02 PM

avatar image

TJ V ♦♦ STAFF
41.1k 1009 183 493

avatar image Deathcheater Nov 24 '15 at 05:37 AM

Im getting this with most of the audio files in the "Blueprints" project of the learn section. I've tried using 4.8 and 4.9 and has the same issue. I haven't tried 4.10 but i can use them fine, I just cant right click them.

avatar image TJ V ♦♦ STAFF Nov 24 '15 at 08:26 PM

Hi Deathcheater,

See if the solution in this post helps you at all.

If not, I would try reinstalling the editor. If the issue persist, please create a new report in the Bug section of AnswerHub, because the above issue was resolved with an update to 4.8. I believe you are experiencing a new issue.

Thanks,

TJ

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question