x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Blueprint compiles successfull but gives Error on hitting Play

I have one blueprint function library which compiles successful if I click "compile" but if I want to start the game then I get a message that I have an unresolved compile Error in the blueprint and in the log this is written:

LogPlayLevel: [PIE] Compiling BP_Functions before PIE... LogBlueprint:Error: [compiler BP_Functions] Error Could not find a function named "Viewport__GetMousePosition" in 'BP_Functions'. Make sure 'BP_Functions' has been compiled for Viewport Get Mouse Position

"Viewport__GetMousePosition" was a node of Ramas victory plugin which I have used some time ago, but I removed it from the project (in 4.7) and now in 4.8 I get this Error that the nodes are missing?

Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 21 '15 at 11:53 PM in Bug Reports

avatar image

John Alcatraz
1.3k 58 139 127

avatar image Rudy Q ♦♦ STAFF May 28 '15 at 03:40 PM

Hello John Alcatraz,

I have a few quick questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. When you say "but I removed it", are you referring to the node that is mentioned or the entire plugin?

  2. If you removed the entire plugin, have you/could you please go through your code/blueprints and make sure that there are no lingering references that you may have been using?

  3. If you have removed the node and are still using the plugin, have you spoken to Rama about the issue?

avatar image John Alcatraz May 28 '15 at 04:08 PM

Hi Rudy!

I have removed the entire plugin back in 4.7, but let the nodes of the plugin (like "Viewport_GetMousePosition" inside of the blueprints. This worked in 4.7 if they were disconnected from an execution path. Then I converted the project to 4.8 and in 4.8 it seems not to be possible to have nodes "floating around" from an missing plugin, even if they are not connected to any execution path. So I deleted the nodes out of the blueprint. But I still get the Error that the nodes would be missing.

avatar image Rudy Q ♦♦ STAFF May 28 '15 at 06:08 PM

Hello John Alcatraz,

Could you send me a link to the exact version of the plugin that was used in your project? I will also need to know how the nodes were being used. I am going to try and remove the plugin and then upgrade a project from 4.7 to the preview and see if I can reproduce the errors that you are seeing. From there I will try and track down what is causing the issue (the plugin or the engine) and take it from there.

avatar image John Alcatraz May 28 '15 at 06:12 PM

I think I actually removed the plugin already in 4.6.1... I think I used this version:

https://d26ilriwvtzlb.cloudfront.net/archive/a/a4/20150219222704%21VictoryPlugin.zip

I have basically just used the ViewportGetMousePosition Node in a function inside of a blueprint function library and just returned X and Y of the node.

avatar image Rudy Q ♦♦ STAFF Jun 02 '15 at 03:51 PM

Hello John Alcatraz,

I was able to reproduce the error that you are seeing on your end. However, after I went through and deleted the remaining nodes the error was gone. I was not able to reproduce the error after the nodes were removed. This leads me to believe that you could have missed a node or two somewhere in your project or that you may still have a reference to this node somewhere. I have included the steps taken to reproduce this issue. Please let me know if there was a difference in our methods that could lead to the issue that you are seeing (if there are no remnants of the victory plugin in your project).

Steps that I took to reproduce this issue:

  1. Created a 4.6.1 project

  2. Added the Victory plugin

  3. Created a function library that used the Viewport get mouse position node

  4. Add a Viewport Get mouse position node to the character blueprint

  5. Added the function from the function library to the character blueprint

  6. Save, Compiled, closed the editor

  7. Removed the plugin

  8. Disconnected the mouse position nodes

  9. Compiled and received errors

  10. Updated (via open a copy) to 4.7.6

  11. Compiled and received warnings

  12. Updated from 4.7.6(via open a copy) to 4.8

  13. Compiled and received errors

  14. Removed the mouse position nodes

  15. Compiled with no warnings or errors of any kind

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello John Alcatraz,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Jun 08 '15 at 06:40 PM

avatar image

Rudy Q ♦♦ STAFF
47.4k 545 132 524

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question