x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

[4.8p3] Tick not firing on Packaged Build Blueprint AActor

I've been running into an issue since 4.8 previews started coming out that for at least one of my actors the Tick event is not firing in packaged builds only. In the editor it works fine. I tried placing debug print to screen statements after the tick event and they fire in the Editor launched version of the project but not my final packaged build. I've spent hours trying to figure out why. Only once did I manage to get a clean build where the Tick event was firing. I went back, removed the print lines and it was back to not firing, with or without the print lines.

There is something odd about 4.8 packaging!

The blueprint has no C++ base classes for me to enable ticks on. In the property sheet I have start with ticks enabled and even ticks enabled on dedicated server not that I need it. I've tried deleting the event and readding it in blueprints. Deleting intermediate files and cooked files, packaging to new directories, to no avail.

Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 22 '15 at 04:37 AM in Bug Reports

avatar image

druidsbane
187 11 21 171

avatar image choel Aug 23 '15 at 12:05 AM

I am having this issue now. Tick is not being called on Child blueprints, only in packaged builds. Play-in-editor, and everything works fine. I've even had another actor set tick enabled and tick is still not being called.

You have this marked as resolved, how did you fix it?

avatar image druidsbane Aug 23 '15 at 12:10 AM

For me I ended up doing a clean rebuild of the engine deleting all intermediate build files, etc... It then just started working. Can't explain it other than I was using my own build not the official ones.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

User resolved, marked as closed.

more ▼

answered May 26 '15 at 02:03 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question