x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Moving & Organizing folders corrupts project structure

I've been having this issue since the old launcher "force update"d me from 4.7.1 (i think, it was 4.7 early version) to 4.7.6 and I've been having an issue ever sicne and maybe before.

I commonly add marketplace items to my projects, but sometimes they are not oganized in hteir own /Game/'MarketplaceItemNameX' folder and I keep my projects meticulouslly organized ie

/Game/Animations /Game/Audio /Game/Blueprints

etc. so what I'll often do is make a new blank project and add the marketplace item to that project then I'll make a folder named 'MarketPlaceItemNameX' and proceed to move all the folders into that folder which I can then migrate to my working project so that I get a nice /Game/MarketPlaceItemNameX folder with all the subfolders in it as to not dirty up my project structure.

Unfortunatly more often than not this removes textures from materials, interface and event dispatcher calls, and especailly aggrivating casts (what did it originally cast to? now the cast node just says "Bad cast", gotta add it back to another new project to go find out).

This became such an aggrivation that I tried out the 4.8-p3 setup, it crashed on my first attempts to even move a folder.

I've tried the whole moving the files, then taking the old folders and doing the "Fix Redictors" option and it tells me its deleting the redirectors, which I do, then it works, but sometimes it doesnt and when I try to delete the "fixed" folder it gives me "Failed to load assets" and that folder is forever stuck there whether I delete it in windows explorer or in editor.

I've seen many examples of this starting from the first versions of UE4 up until now. I havnt been able to find a bug report tracking # to see if its being worked on, so I'm reporting it again.

I've heard that using the "Reference Viewer" option on each file, and manually creating the folder structure and then moving each file 1 by 1 and doing it using the Reference Viewer going from right to left (IE for a basic material, move the textures first, then the materal) but this is very time consuming.

You would think simply moving some folders from the root directory to FolderX would be no problem (I know it isnt in Unity, but I've given up on Unity 100% since about 4.6.1). Its currently my biggest downside to UE4 and ends up causing a LOT of crashes.

To TRY to replicate, make a new FPS template then move all the files within "FirstPersonBP" to the root content folder. When you try to delete the (now empty, except the redirectors) you get reference errors, so then I cancel and do a "Fix Redictors" and then accept it to delete the redirectors and then I delete the folder one more time and its gone (in the editor and Windows explorer). I do this for all the folders, of course the maps have to be moved manually. The last time I did this to replicate I created an empty level and opened it after creating the Animations, Audio, Character etc. folders in the root content folder to move /FirstPersonBP/'s content to.

Next time you open the project and hit play, the crosshair is gone (in my last case) even though the HUD class is setup fine and the gamemode is setup fine. But when I reselect the texture and reselect the HUD class in the GM, everything is fine again. Not a big deal, but a HUGE deal if your dealing with a marketplace item such as ALCS which you paid 130 dollars for.

Thanmks.

Product Version: UE 4.7
Tags:
more ▼

asked May 23 '15 at 04:38 PM in Bug Reports

avatar image

Nsomnia
1.8k 67 27 137

avatar image Nsomnia May 26 '15 at 12:14 PM

Oh and then alot of the time I get this error when I try to agree to delete the redirectors after trying redirectors and then everything goes bad.

Its a terrible feeling developing knowing a single file move may corrupt work and you'll have to migrate what you can and re-write what needs rewriting.

http://i.imgur.com/YVOUWHi.png

avatar image Adam Davis STAFF May 27 '15 at 03:35 PM

Hi Nsomnia,

Unfortunately I'm having a bit of trouble following what you are saying. Are you changing the folder structure before migrating content and then the references break when you move them? If so try this:

  1. Move the assets to your new folder structure in the first project.

  2. Fix up redirectors on the content folder (this will propagate to all subfolders)

  3. Migrate the content to the same folder structure in the new project.

It sounds overall like the problem is the multiple folder structure changes. If you fix up redirectors before migrating and ensure that you are migrating the content to the same filepath in a different project (so \Unreal Projects\PROJECT1\content\folder1\ moves to \Unreal Projects\PROJECT2\content\folder1) it should work without giving you those errors.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Any ideas?

more ▼

answered May 26 '15 at 03:50 PM

avatar image

Nsomnia
1.8k 67 27 137

(comments are locked)
10|2000 characters needed characters left

Hi Nsomnia,

We have not heard from you in some time. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment back with the requested information.

more ▼

answered Jun 02 '15 at 07:15 PM

avatar image Asher S Einhorn Oct 22 '15 at 12:35 PM

This is still happening in 4.9 in a major way. broken references, copied files, copied folders, things moved to the root and duplicated and so on. files refusing to appear in the solution. complete carnage.

avatar image Adam Davis STAFF Oct 22 '15 at 01:55 PM

Hi Asher S Einhorn,

Did you try the steps I listed above to see if it resolved your error?

(comments are locked)
10|2000 characters needed characters left

This is still happening in 4.18, at very this moment. Though you move the folder, the original folder does not disappear, although it does not have any file in it.

Hopefully, 3 steps of Adam Davis STAFF works. But keep in mind that, do not delete original folder structure which remains after MOVE. If you delete it (though after moving and Click 'fix up redirectors'), link can be broken. just Migrate to the new project that you prepared.

more ▼

answered Dec 05 '17 at 01:08 AM

avatar image

olim_simon
8 5 6

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question