x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

adding variable to struct causes crash of engine

I'm able to add members to a new struct and other structs, but once the struct is used inside some blueprints the ability to add to that struct is no longer viable as when you do it causes the whole engine to crash. I can save changes to the struct on existing members, but can't add any new ones. I've tried to track down the exact moment / use case for what's causing it but have yet been able to pin point it. I first ran into it in 4.7 but tried 4.8 preview 3 to see if some of the proposed possible struct fixes were in yet or working or if the blueprint improvements solve the problem, but no luck yet.

There is an error report spawned every time it happens. I'm thinking it might of started being a problem after I started trying to add it to a save object, but have to do some rolling back to test in more details if that is the case.

Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 24 '15 at 01:13 AM in Bug Reports

avatar image

Keeperofstars
1 1 2 4

avatar image Ben Halliday STAFF May 28 '15 at 07:25 PM

Hi Keeperofstars,

I'm not sure I have enough information to try to reproduce this internally. So if I create a new struct, what and how do I need to use it in a Blueprint to test this? And where/how are you adding to the struct? Dynamically or in the struct itself?

Can you also find the log from your project after this crash occurs and zip/attach it here? The information from the crash reporter dialogue window would be helpful as well. Thanks!

avatar image Keeperofstars May 30 '15 at 12:18 AM

Here is the log, the crash dump has no information in it. besides machine and epic id. I think the top failure line is the key aspect where the array index out of bounds 8 from an array of size 8. Note the structure has 8 elements in it before I try adding another element to the structure via the structure user interface. I can remove an item from the struct, and save it no problem. If i do that then try to add another item it becomes 7 out of 7 on the array bounds. I'm going to fully rebuild it again from ground up testing each step of the way to see if I can reproduce and catch the step that is tripping it up.

Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.7\Engine\Source\Runtime\Core\Public\Containers\Array.h] [Line: 679] Array index out of bounds: 8 from an array of size 8

KERNELBASE.dll!UnknownFunction (0x00007ffc265518f8) + 0 bytes [UnknownFile:0] UE4Editor-Core.dll!FOutputDeviceWindowsError::Serialize() (0x00007ffc05c38074) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsplatformoutputdevices.cpp:95] link text

error log.txt (8.7 kB)
avatar image Keeperofstars May 30 '15 at 03:19 AM

Added follow up found the issue aspect. So rebuilt my whole project and found the root source of the bug. Once the struct is in use in blueprints, and you move it's location to a folder path that is not in the same top level folder path as it's current location. It breaks the ability to add structure elements at that point. Going to start a clean project and refine the test case now. But example of path was /content/character/ that then had the sturct bp in it. Then moved it to /content/testfolder/ at that point it broke the struct. I just used the drag and drop and move to option inside the engine.

avatar image Ben Halliday STAFF May 30 '15 at 04:05 PM

Thanks for digging into it further! I'm still not able to reproduce this crash, though; moving the struct to another folder didn't cause any issues with adding a new element to it, whether the struct was used in another Blueprint or not. If you're able to refine the repro steps for me, that would be greatly appreciated!

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Unreal has got a problem of crashing if the struct is changed while the struct is linked up inside a FOR LOOP or linked in many FOR LOOPS from different blueprints wherever the struct is being used... Try moving the struct into a new folder WHILE the struct is running INSIDE OF A FOR LOOP in one blueprint or is linked up in a dozen blueprints and see if it then misbehaves.

more ▼

answered Nov 18 '18 at 06:12 AM

avatar image

tozan
11 3 4

avatar image KingVario Nov 26 '18 at 07:51 PM

I can confirm this workaround works for now, if you move the structure into a new location edit it then move it back it works without crash. I wish Epic Games had a good QA team, there are so many show stopping bugs that need time consuming workarounds.

(comments are locked)
10|2000 characters needed characters left

Hey Keeperofstars,

We haven't heard back from you in a while, so I'm resolving this post for tracking purposes. If you're still experiencing this issue and are able to provide reproduction steps in a new project, please feel free to update us and we'll continue investigating. Thanks!

more ▼

answered Jun 03 '15 at 04:49 PM

(comments are locked)
10|2000 characters needed characters left

Show stopping is right. Time consuming is the biggest problem with this engine. It takes a very long time to make a game because of the bugs you have to work around in this engine...

more ▼

answered Nov 26 '18 at 11:13 PM

avatar image

tozan
11 3 4

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question