Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Disable material "shine"

At start - sorry for my English. When I start design environment I saw this material shine.

material shine

My question is - How can I disable it?

alt text Here is my landscape material.

Product Version: UE 4.7
more ▼

asked May 24 '15 at 03:36 PM in Using UE4

avatar image

1 1 2 1

(comments are locked)
10|2000 characters needed characters left

4 answers: sort voted first

Go to the material properties, you should be in the blueprint now, once you are there make a constant, put it as a high number, then connect it to roughness and TADAA the shine is gone for good (unless you take it off)

more ▼

answered May 24 '15 at 05:25 PM

avatar image

26 5 11 16

avatar image TheKkubas May 25 '15 at 02:09 PM

Thank you. Problem disappeared.

(comments are locked)
10|2000 characters needed characters left

Open the material editor and check this box. That should work (it worked for me, I was just reading this topic)

[1]: /storage/temp/222045-sem-titulo.png

sem-titulo.png (47.3 kB)
more ▼

answered Nov 30 '17 at 04:47 PM

avatar image

13 1 3

(comments are locked)
10|2000 characters needed characters left

You need to connect "LandscapeCoords" to your TextureSample UV input pin. I believe the "shine" is just the white dots from your first texture, stretched across the landscape.

more ▼

answered May 24 '15 at 05:16 PM

avatar image

21 2 3 6

(comments are locked)
10|2000 characters needed characters left

The standard material in Unreal Engine has three basic attributes:

  1. Metallic, or how metallic an object is.

  2. Specular, or how much light it reflects.

  3. Roughness, or how far the light spreads when it does reflect.

All of these values can be used to shape what your material will look like, and they can be modified by attaching a "Constant" Node (hold the "1" key and click to place) to the Material.

All of these values default to 0.5, which is dumb, so it's good to get into the habit of setting them each time. They also are clamped to values between 0.0 - 1.0.

There are several ways to make light not reflect as you say, but I would recommend setting the Specular and Metallic value to 0, or something very close. Setting Roughness to 1 would also solve the problem, but it technically would still be reflecting light, like a carpet made of glass.

more ▼

answered Nov 30 '17 at 06:12 PM

avatar image

31 4 8 12

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question