x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Copy Paste Blueprints Nodes broken

After copy and paste my nodes from 4.7.6 to 4.8 P3 the var rotator is unknow and after select create var from this, now my project is Blueprint is broken the var no idea where is defined but don't is in my list of vars and the Bluepritn report all time em a error of compilation the defined var is unknow OMG.

And now i can't remove the VAR how fix this because now i can't do NOTHING.

Product Version: UE 4.8 Preview
Tags:
more ▼

asked May 25 '15 at 03:15 PM in Bug Reports

avatar image

Hevedy
633 60 76 112

avatar image Hevedy May 25 '15 at 06:23 PM

After restart the editor, the engine drop me a msg about the bad status of that nodes and the option to remove, after press ok, now looks like is fixed.

avatar image Adam Davis STAFF May 26 '15 at 05:30 PM

Hi Hevedy,

Just for clarification, this is no longer occurring for you? If it is still a problem, what steps did you take that reproduce this on your end?

avatar image Hevedy May 26 '15 at 06:09 PM

Yes the copy paste is bad, you can copy nodes from 4.7 for example and paste in the 4.8 for example the trace nodes, for loops and custom vars like rotations paste bad or don't paste.

If you create a var from a pasted node rotation from the option create a var from this node, then create a bad var with a non true class and don't show in the explorer, and give error at compile the blueprint, you need restart the engine to get the msg of "You like remove the bad vars ?" then press ok and fix this.

avatar image Adam Davis STAFF May 27 '15 at 03:40 PM

Are you copying and pasting between projects or are they from the same project but one is in 4.7 and one is in 4.8? Additionally do you already have a copy of those variables in the 4.8 project or are they being pulled over and no local copy has been made?

avatar image Hevedy May 27 '15 at 05:56 PM

Different projects, and different versions. From 4.7 to 4.8 selecting the nodes in the view and then paste in the 4.8 view. (Custom rotation vars or traces nodes or forloops... try with that)

avatar image Adam Davis STAFF May 28 '15 at 02:47 PM

in your 4.8 project did you have the variables you were moving over already made? If not the bad variables may be because it didn't find any reference to those variables when moved over. Try creating the variables in your blueprint then move the blueprint itself over.

avatar image DLROKen Sep 11 '18 at 10:40 AM

4.20 isn't letting me copy and paste anything inside any blueprint editor window.

avatar image Everynone Sep 11 '18 at 11:21 AM

4.20 isn't letting me copy and paste anything inside any blueprint editor window.

@DLROKen:

You've bumped a 3 year old question, do you think you'd be the only one to notice that copy paste is not working? :)

Certain nodes may not be available in all contexts. Copy paste a Print String node and see that is works rather well.

Alternatively, please do produce an example of what is not working; saying that nothing does is simply not true.

avatar image conleydesign Sep 16 '18 at 10:34 PM

4.20.2 Isn't letting me copy and paste anything inside any blueprint editor window HOW TO FIX THANK YOU...

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Hevedy,

Thank you for the updated information. I was able to reproduce this on my end and have entered a bug report, UE-16429 to be assessed by the development staff.

more ▼

answered Jun 01 '15 at 05:20 PM

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question