x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Closed] Code-Based Project still not packaging Plugin

Hi guys!

In an attempt to package my otherwise blueprint-only project with Rama's Victory plugin (awesome work, Rama), I added four empty code classes to my project - two pawns, a PlayerController, and a completely empty class.

When I try to build the resulting project, the buildtool breaks with the following error text in UnrealBuildTool.txt:

 Parsing headers for Arena
 Reflection code generated for Arena
 Performing 13 actions (4 in parallel)
 [3/13] Resource Arena.rc
 PCH.UELinkerFixups.UELinkerFixupsName.h.cpp
 PCH.Arena.Arena.h.cpp
 UELinkerFixups.cpp
 Arena.generated.cpp
 VictoryPluginPC.cpp
 VictoryPawn2.cpp
 VictoryPawn.cpp
 VictoryEmpty.cpp
 LevelUpData.cpp
 Arena.cpp
 HTTPStreamingASync.cpp
 [13/13] Link Arena.exe
 LINK : fatal error LNK1181: cannot open input file 'C:\Program Files\Epic Games\4.7\Engine\Plugins\VictoryPlugin\Binaries\Win64\VictoryBPLibrary-Static.lib'
 -------- End Detailed Actions Stats -----------------------------------------------------------
 ERROR: UBT ERROR: Failed to produce item: C:\Users\Billy\Dropbox\Projects\Arena\Unreal\Binaries\Win64\Arena.exe
 Cumulative action seconds (4 processors): 0.00 building projects, 34.58 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.10 linking, 0.00 other
 UBT execution time: 43.01 seconds

The .lib file referenced does not exist in the downloadable version of Rama's plugin, and therefore is not at the location referenced. Is that created afterwards, or is this error just a symptom that my project is still blueprint-only?

edit: bumping this thread to add that I've added actual code to my project in order to implement a custom datatable structure. Trying to remove this plugin, even following Rama's instructions, causes my project to crash, and I can't package it while the plugin is still attached.

Can anyone help? :(

Here's the crash data: (super long) http://pastebin.com/CGjLArRT

Product Version: UE 4.7
Tags:
more ▼

asked May 27 '15 at 09:06 PM in Packaging & Deployment

avatar image

Anaklu
1 1 2 4

avatar image Rama May 29 '15 at 04:58 PM

As has been mentioned many times on the forums, until 4.8 you need to have Visual Studio and recompile my plugin for your project yourself in order to package it.

This restriction should be going away in 4.8, the closer we get to plugins being available on the marketplace.

Uploading

I'm going to package and upload a 4.7.6 version, which has a much higher file size but includes the static lib.

avatar image Anaklu May 29 '15 at 05:37 PM

Worked perfectly! Thank you for packaging it again for me, I probably would have screwed up the VS build as well ^_^

(comments are locked)
10|2000 characters needed characters left

The question has been closed Jul 07 '16 at 03:11 PM by Samantha Sutton for the following reason:

The question is answered, right answer was accepted


1 answer: sort voted first

Solution, Download For You

Hi there!

I've packaged my plugin with a sample project in 4.7.6 in order to produce the static lib, it is in my May 29th 2015 build which has the noticeably higher download size of 7.8mb

UE4 Wiki Link

https://wiki.unrealengine.com/File:VictoryPlugin.zip

Please let me know if this is sufficient to enable you to package.

Have fun today!

Rama

more ▼

answered May 29 '15 at 05:07 PM

avatar image

Rama
10.5k 443 340 1078

avatar image Chaoss Aug 20 '15 at 09:38 AM

When are you releasing the plugin for 4.8?, it works in the editor but will not work for packaged builds

avatar image Anaklu Aug 20 '15 at 05:30 PM

I just packaged my game in 4.8 with the VictoryPlugin and played it successfully.

avatar image FearTheFuzZY Dec 11 '15 at 01:15 AM

Which version of the VictoryPlugin do I need to have it work on Unreal 4.8.1?

I see a long list but I am not sure which plugin to download.

(comments are locked)
10|2000 characters needed characters left

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question