x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

PhysX Crash

I have a crash occurring sometimes, but it's absolutely not reproducable and is not happening too often.

This is the log:

 [2015.05.27-23.20.44:798][585]LogCrashTracker: 
 
 
 [2015.05.27-23.20.44:798][585]LogThreadingWindows:Error: Runnable thread TaskGraphThread 3 crashed.
 [2015.05.27-23.20.44:798][585]LogCrashTracker: 
 
 
 [2015.05.27-23.20.44:798][585]LogWindows: === Critical error: ===
 Fatal error!
 
 Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000010
 
 PhysX3PROFILE_x64.dll!UnknownFunction (0x000007fed0935210) + 0 bytes [UnknownFile:0]
 PhysX3PROFILE_x64.dll!UnknownFunction (0x000007fed08f0e96) + 0 bytes [UnknownFile:0]
 PhysX3PROFILE_x64.dll!UnknownFunction (0x000007fed08f81d8) + 0 bytes [UnknownFile:0]
 PhysX3PROFILE_x64.dll!UnknownFunction (0x000007fed07964e2) + 0 bytes [UnknownFile:0]
 UE4Editor-Engine.dll!TGraphTask<FPhysXTask>::ExecuteTask() (0x000007fed77ddcd1) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\async\taskgraphinterfaces.h:671]
 UE4Editor-Core.dll!FTaskThread::ProcessTasks() (0x000007feda324fa5) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:428]
 UE4Editor-Core.dll!FTaskThread::ProcessTasksUntilQuit() (0x000007feda32518d) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:271]
 UE4Editor-Core.dll!FTaskThread::Run() (0x000007feda3339cb) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:562]
 UE4Editor-Core.dll!FRunnableThreadWin::Run() (0x000007feda587346) + 0 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
 UE4Editor-Core.dll!FRunnableThreadWin::GuardedRun() (0x000007feda57c32d) + 8 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
 kernel32.dll!UnknownFunction (0x00000000775659cd) + 0 bytes [UnknownFile:0]
 ntdll.dll!UnknownFunction (0x000000007769b981) + 0 bytes [UnknownFile:0]
 ntdll.dll!UnknownFunction (0x000000007769b981) + 0 bytes [UnknownFile:0]
 
 Crash in runnable thread TaskGraphThread 3
 
 [2015.05.27-23.20.45:071][585]LogExit: Executing StaticShutdownAfterError
 [2015.05.27-23.20.45:071][585]LogWindows:Error: Error reentered: Runnable thread TaskGraphThread 3 crashed.
 [2015.05.27-23.20.45:071][585]LogWindows:Error: HandleError re-entered.
 [2015.05.27-23.20.45:071][585]LogWindows: FPlatformMisc::RequestExit(1)
 [2015.05.27-23.20.45:071][585]Log file closed, 05/28/15 01:20:45

And this is what the CrashReported says:

 MachineId:C093024B4F8D72EA90A2EBB7201E91B6
 EpicAccountId:02d0ec4128004fd98b3c89b8afc7933d
 
 Access violation - code c0000005 (first/second chance not available)
 
 PhysX3PROFILE_x64 + 2773520 bytes
 PhysX3PROFILE_x64 + 2494102 bytes
 PhysX3PROFILE_x64 + 2523608 bytes
 PhysX3PROFILE_x64 + 1074402 bytes
 UE4Editor_Engine!TGraphTask<FPhysXTask>::ExecuteTask() + 449 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\public\async\taskgraphinterfaces.h:671]
 UE4Editor_Core!FTaskThread::ProcessTasks() + 3125 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:428]
 UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() + 77 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:271]
 UE4Editor_Core!FTaskThread::Run() + 11 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\async\taskgraph.cpp:562]
 UE4Editor_Core!FRunnableThreadWin::Run() + 102 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]
 UE4Editor_Core!FRunnableThreadWin::GuardedRun() + 93 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.7\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:26]
 kernel32 + 88525 bytes
 ntdll + 178561 bytes
 

It's really not happening too often, I got this crash for 6 or 7 times in total now, every few days. It's mostly happening while spawning an Instanced Static Mesh Component, or spawning an Actor which has an Instanced Static Mesh Component inside, or adding an Instance to an Instanced Static Mesh Component. Not completely sure. Because this is all happening together in my game.

The game just freezes, and then after like 10 seconds freeze UE4 gets closed and the Crash Reporter shows up.

And it's not reproducible, I do the same thing in my game dozens of times each day and nothing crashes. So I also can't really try whether it still occurs in 4.8.

Product Version: UE 4.8
Tags:
more ▼

asked May 28 '15 at 01:15 AM in Bug Reports

avatar image

John Alcatraz
1.3k 57 139 125

avatar image AndrewHurley May 28 '15 at 06:39 PM

Hey John,

Unfortunately unless we have some way of reproducing the crash on our end, it will be incredibly hard to track down where the crash is occurring so we can find a fix for the issue. If there is a blueprint or a set up you believe will reproduce the crash in an empty project we can take that and work from there. Thank you for taking the time to create the report.

Regards,

Andrew Hurley

avatar image John Alcatraz May 28 '15 at 07:09 PM

Hi Andrew,

I know it's really hard for you to fix this without having repro steps, but it's not reproducible so I will never be able to give you anything which would reproduce this. Couldn't you just take a look into the code where the crash occurs and see what there could cause an "Access Violation"?

avatar image AndrewHurley May 28 '15 at 09:15 PM

If you would like to send us the bare minimum of the project to test, that would be helpful, but aside from that simply looking at the log does not provide enough information.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi John,

I apologize for any confusion. The PhysX crash reports can be deceptive, and usually there isn't enough information in them for the developers to work with. The original issue Andrew entered (UE-18808) was marked as a duplicate of another we are more actively tracking (UE-22078). The devs have requested a repro case, and I'm making sure that the newer report has a link to the 4.8 project you provided. I'll follow up with the devs to let them know we have a test case to work with in case they are not already aware.

For right now, the bug is unresolved, but I'll keep an eye on it as well as this post. I will update this post when I see any update, and let you know if the devs require any additional information. I appreciate your patience in this matter.

more ▼

answered Oct 30 '15 at 05:03 PM

avatar image John Alcatraz Nov 14 '15 at 09:22 PM

Hi Ben, may I ask about whether there is any update on this yet? I can confirm the bug is still in 4.10, and since it's making my game quite unplayable without any possible workaround I hope it can be fixed in something like a hotfix for 4.10 :)

avatar image Ben Halliday STAFF Nov 17 '15 at 05:49 PM

Unfortunately I have not seen any change in the report's status. I'll send an email to the devs involved and see if I can get a status, or see if they need any additional info, though I cannot guarantee they'll have anything for me.

avatar image John Alcatraz Nov 25 '15 at 03:04 PM

Hi Ben, what have the devs answered to you? If they could tell me any possible workaround that would already help a lot. At the moment the game is just crashing all the time when placing walls and thats a core element of the game, so it's unplayable. I really need some kind of workaround or fix. Once a fix is available I would merge it myself into 4.10 so even if it won't be in a hotfix that would not really be a problem.

avatar image Ben Halliday STAFF Nov 25 '15 at 07:13 PM

Hi John,

I never heard back. I'll ask again. There's been no update on the bug report at this time, and unfortunately I'm not aware of any workaround for the issue.

avatar image John Alcatraz Dec 15 '15 at 03:07 PM

Hi Ben, have the devs answered you this time?

avatar image Ben Halliday STAFF Dec 15 '15 at 03:09 PM

Not directly, but the bug report was just reassigned. The current thought is this is a crash in destruction, and the devs are investigating that at the moment.

avatar image John Alcatraz Dec 15 '15 at 03:12 PM

Thanks for the update! I think I don't use any destructibles in the project, but maybe with "destruction" you mean "when the destructor is executed"?

avatar image Ben Halliday STAFF Dec 15 '15 at 03:16 PM

That's what I was thinking =)

avatar image John Alcatraz Feb 05 '16 at 03:00 AM

Hi Ben, I think I saw a commit that finally fixed this bug in 4.11, am I correct? :)

avatar image Ben Halliday STAFF Feb 05 '16 at 03:22 PM

Yes. It hasn't been verified completely yet, but we have a fix in 4.11 with this commit:

https://github.com/EpicGames/UnrealEngine/commit/e09f279825be41f28d10f94e329e3d6de6efb9c2

This won't have made it to the 4.11 P4, but might make the next one if we continue Previews for this version.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey John,

I have entered a bug report for this issue after successfully reproducing the crash. The issue is UE18808 and I cannot currently say when this will be addressed and fixed. Thank you for the report and your patience during the reporting process.

Regards,

Andrew Hurley

more ▼

answered Jul 17 '15 at 04:04 PM

avatar image John Alcatraz Jul 17 '15 at 04:59 PM

Great, thanks!

avatar image John Alcatraz Aug 24 '15 at 04:56 AM

Hey Andrew, could you give me any update on this? Is it fixed in 4.9? I can't find UE-18808 in the known issues list for 4.9, but I guess that does not automatically mean that it's fixed.

avatar image AndrewHurley Aug 24 '15 at 01:19 PM

This has been marked for 4.10 and has not been addressed as fixed as of late.

avatar image John Alcatraz Aug 24 '15 at 02:41 PM

Oh, is there any reason written why not for 4.9? I thought for you at Epic fixing bugs which lead to crashes has highest possible priority?

avatar image AndrewHurley Aug 24 '15 at 03:24 PM

The issue was not effecting enough users to gain the highest priority. This doesn't mean we have ignored it, as it is marked for 4.10.

avatar image John Alcatraz Oct 10 '15 at 08:06 PM

Hi Andrew, any update? If there already is a commit somewhere which fixes this, could you please link it so that I could manually add it to 4.9?

avatar image AndrewHurley Oct 12 '15 at 09:03 PM

Hey John,

There is no specific changelist or fix for this integration as there were a number of destruction bug fixes implemented which helped clear this issue. With that in mind, I have reached out to them and asked for an update.

A couple of questions:

Are you still experiencing this crash in 4.9.2?

Are you using the AMD Raedeon card you mentioned to recently moved to?

avatar image John Alcatraz Oct 12 '15 at 09:36 PM

Hi Andrew, thanks!

Yes, I am still experiencing this crash in 4.9.2, more than ever before. If you take a look at the crash reports you will probably find a few dozen reports where my engine crashed with the PhysX crash the last few days.

You say there were "a number of destruction bug fixes implemented which helped clear this issue", so it is marked as fixed now? I don't use any destructibles at the moment when the crash appears, only Instanced Static Meshes.

I am using the Radeon R9 390 I recently moved to, yes. I can't play in standalone with it because the AMD driver will crash after a few seconds, but PIE works a lot better. Why do you think is it important for this issue? Isn't PhysX only calculated on the CPU?

avatar image AndrewHurley Oct 13 '15 at 06:52 PM

You will find the PhysX FAQ very helpful, when answering your question :)

http://www.geforce.com/hardware/technology/physx/faq

avatar image John Alcatraz Oct 13 '15 at 06:57 PM

UE4 is running PhysX on the CPU only. Am I knowing the engine better than you? ^^

Why do you link the FAQ? Linking the FAQ does surely not resolve the issue. It's also not about UE4s PhysX implementation.

avatar image AndrewHurley Oct 14 '15 at 03:25 PM

Hey John,

You were correct as UE4 does run on the CPU side. Apologies for the mistake. We are still trying to narrow down the ability to reproduce this issue on our end, but we do not have enough to generate the crash.

When this bug was originally reported, you provided me with a test project. I attempted to upgrade that project to get the crash occur in 4.9.2 but haven't been able to do so.

If you have any sort of way to reproduce this issue, it would be most helpful.

Thanks,

Andrew Hurley

avatar image John Alcatraz Oct 14 '15 at 05:51 PM

Hi Andrew,

The same repro steps which worked in 4.8 still work in 4.9.2. Above you sounded like UE-18808 was marked as fixed, so is it or is it not?

I sent you the repro steps in a PM a few months ago, and because of the very low saved message limit in the forums I had to delete it, but after a bit of trying I still remember it and it crashes the editor same in 4.9.2 like in the previous versions. Are the repro steps not explained within the UE-18808 bug report?

Just open the project, hit play, press "g", click and hold the left mouse button and move the mouse, then release left mouse button (a wall should appear), do the same again somewhere else, crash.

avatar image makai Oct 14 '15 at 06:11 PM

hey just found this topic, i have also physx crash, all i needed to do is to take an actor, add physical material with negative friction so it slides and let it move over the terrain, after some time it will freeze and then crash.

avatar image John Alcatraz Oct 28 '15 at 02:25 AM

Hey Andrew, do you still look into this? You have asked me for the repro steps 2 weeks ago and I have not heard anything back from you after I explained to you how to reproduce it.

avatar image AndrewHurley Oct 14 '15 at 09:20 PM

Hello makai,

I just attempted reproducing the crash with the information you provided, but was unable to do so.

Would you mind providing me with some clear reproducible steps so I can get this to occur in a blank project? Perhaps you can point out where our steps differ.

  • Created a new blank blueprint project (no starter content)

  • Created new landscape actor (default settings)

  • Added large incline on landscape using ramp tool

  • Placed three basic sphere actors at the top of the ramp.

  • added a physical material to the spheres and the landscape and set its friction to a negative value.

  • Checked the, 'Simulate physics' option for the spheres

  • Pressed Play in Viewport

Let me know if this is sufficient enough to reproduce the crash, and if there are things I can do to get the crash to occur.

Thanks,

Andrew Hurley

avatar image John Alcatraz Oct 14 '15 at 09:31 PM

Hey Andrew, I think the crash from makai is something different since it does not seem to have to use instanced static meshes.

Were you able to reproduce my crash now or why have you marked it as resolved?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey John,

I was just notified of a bug report that was generated from a similar crash you are experiencing, and as you mentioned on here as well as noted in the report, the repro is hard to come by. However, since the bug report has already been made for this issue, if you have a test project in which you can provide that has had the issue occur, send that to me so I can attempt to get the repro on my end.

Thank you,

Andrew Hurley

more ▼

answered May 29 '15 at 02:48 PM

avatar image John Alcatraz May 29 '15 at 04:21 PM

Hi Andrew, unfortunately I don't have a test project for this. As I said this bug is happening not really often, so I would have to use a test project for like 3 days to one week until I would know whether the bug occurs there or not. I think the only possible way to fix this bug is to look at the code where the editor is crashing and see what there could cause an Access Violation, I thought the information in the callstack (PhysX3PROFILE_x64 + 2773520 bytes) is basically saying in which code line the crash occurs?

avatar image John Alcatraz Jun 12 '15 at 12:29 AM

Unfortunately the crash still occurs in 4.8.

avatar image John Alcatraz Jul 14 '15 at 04:13 AM

I get this crash (or a similar one) really often now... And after the crash UE4 does not even close, it just stays opened. So I see the crash reporter, click on "send and restart", the project opens again, but the old crashed one just stays opened, but is freezed. And I only see half of the callstack in the log because the engine seems to crash before its able to fully write in the log. Were there any fixes for crashes like this in the last months added to the master branch?

avatar image AndrewHurley Jul 14 '15 at 09:16 PM

Hey John,

I am looking at your most recent crash now, and if you could please provide me with some way to reproduce this issue on my end. What is it in this project that is using Nvidia PhysX and roughly what are you usually doing when this crash occurs?

avatar image John Alcatraz Jul 14 '15 at 09:31 PM

Hi Andrew, thanks, I am just adding and removing instances to instanced static meshes and tracing a lot for instances while I add and remove the instances... So I don't really use any physics stuff, except that the instances of course have collision. I've tried to reproduce it in a new project, but I can't. I have also tried it in the promoted branch, crashes there too.

avatar image AndrewHurley Jul 14 '15 at 10:26 PM

Would you mind showing me this process or providing me with some type of test case so I can get it to occur on my end?

avatar image John Alcatraz Jul 15 '15 at 01:10 AM

I guess sending you the project is the only way to show you the crash... Will sent you a PM in the forums with the download link.

avatar image AndrewHurley Jul 15 '15 at 02:56 PM

Hey John,

There must me some corruption somewhere within your project which is causing issues. I cannot test the project because as soon as I press play it freezes. I also attempted to open the Wall blueprint asset you mentioned, and it also freezes up my editor.

Also, I noticed you have a destructible mesh within the engine which is going to be using PhysX. This could be the cause or focus of why your project is crashing. You said you cannot reproduce this in a blank project, which means it is specific to what you have established in this project. At this point even if I were to enter a bug with the crash logs you have provided attached, it would have not direction as there is no logical steps to follow in order to reproduce the crash. We need these steps to help us determine the cause of the issue and where to address the fix.

Perhaps try resending the project with the absolute bare minimum assets. I only need your Config, Content, and Uproject files zipped into the folder.

Regards,

Andrew Hurley

avatar image John Alcatraz Jul 15 '15 at 07:48 PM

Hi Andrew, thanks, but please try again. I know the first time you start up the editor hitting play will need 1 to 3 minutes until the game starts, but that's usual. If you then stop the game and hit play again it starts immediately, it's just because on first hitting play the editor compiles all blueprints which takes some time. The crash is very reproducible, just do the steps I send you in the PM. If you just need the Config, Content and uproject files you can just delete the other folders, but then you will first have to wait 2 or 3 hours on first startup because it will need to compile all shaders then... So I thought its better to send you the project including all the folders.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question