Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

blenderからのskeletal model読み込み方法


blender2.69 から出力したskeletal model をue4で正しく表示する方法を知りたいです。 link text

unityと同じようにy up でfbxを出力したら本当に y 軸を向きました(不幸にも ue4 は z up です z up にしても y 軸を向きました。

一方 static mesh はy up でも期待通りの向きを向きました。

fbx import 時にwarning 表示されましたlink text


↑元のblend ファイルも置きます

Product Version: Not Selected
mecanimtest.zip (351.5 kB)
ue4_warning.txt (1.5 kB)
more ▼

asked Apr 02 '14 at 02:15 PM in Japanese

avatar image

3 1 2 3

avatar image masak Apr 11 '14 at 02:07 PM

ありがとうございます! バージョン4.1を楽しみにしています

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first





more ▼

answered Apr 09 '14 at 09:51 PM

avatar image

Joe Conley STAFF
361 39 5 18

(comments are locked)
10|2000 characters needed characters left
Viewable by all users


Warning An out of date FBX has been detected. Importing different versions of FBX files than the SDK version can cause undesirable results.

File Version: 6.1.0 SDK Version: 7.3.0


Warning FBX bind pose 'BIND_POSES' is invalid. It will be ignored Warning Warning: The following bones are missing from the bind pose. If they are not in the correct orientation after importing, please set the "Use T0 as ref pose" option or add them to the bind pose and reimport the skeletal mesh

Blenderにバインドポーズが正しく設定されませんか又はBlenderのFBXエクスポート時にバインドポーズを正しくエクスポートしないみたいです。UE4にインポートする時、バインドポーズが正しくないのでバインドポーズをz-upにコンバートできないです。出来ますと、Blender上にバインドポーズを修正しますと治ると思いますが、Blenderのエクスポート時にバインドポーズ周りに問題があって修正出来ないですと、UE4にインポートする時に「Use T0 as Ref Pose」オプションを選択しますと、正しz-upになります。

alt text

ちなみに、mecanimtest.fbxをMayaで開いて再度FBXにエクスポートしますと、問題なくUE4にインポートしますので、BlenderじゃなくてMayaか3DS Maxを使用できますとより簡単にエクスポート・インポートできると思います。そしてメッシュ自体は非常に小さいですが、スケールをより大きくにしますとUE4のスケール(1ユニット=1センチ)にもっとよく一致すると思います。


usetoasrefpose.png (72.7 kB)
more ▼

answered Apr 02 '14 at 10:48 PM

avatar image

Joe Conley STAFF
361 39 5 18

avatar image masak Apr 03 '14 at 01:36 PM


「Use T0 as Ref Pose」オプションは、Z up 問題を解決してくれました!


blender fbx exporter で scale を 100 倍にしてみました。

skeletal model は zup で正しく表示されました。

しかしAnimation が変です。


Skelton scale 1倍だと正しいAnimation になります。


alt text alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question