x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Error UnrealEngineInstaller-1.0.0-2039063.msi on install

So my hard drive crashed and have to reinstall the Epic Games Launcher, when I do I get the following error. alt text

I have searched on my hard drive and can not find the file. I cleared out the temp fold just in case, also ran it as admin in the command prompt. I am running window 7, I was wondering if I can have some help.

Thanks James

Product Version: Epic Games Launcher
Tags:
error.jpg (12.4 kB)
more ▼

asked May 28 '15 at 07:37 PM in Installation & Setup

avatar image

Shadow_1138
1 1 2 3

avatar image TJ V ♦♦ STAFF May 28 '15 at 08:20 PM

Hi Shadow_1138,

You mentioned that your hard drive just crashed. Did you have to reinstall Windows or did you just restore back to a previous date?

Either way, make sure that you are up to date on all software updates. All other users I have found with this same error were either using 32-bit Windows or were missing important system updates.

Also, try the suggestions in this section of the troubleshooting steps.

avatar image 0xDEADBEEF STAFF May 28 '15 at 09:19 PM

Do you have an Unreal engine entry in your Add-Remove-Programs? If so, try to uninstall it first before running the new installer.

avatar image Shadow_1138 May 29 '15 at 07:50 PM

I should explain more, sorry for not giving the details. So my f drive crashed that had all my projects and engines on it. so I got a new drive then decided to uninstall the launcher (because I thought it was installed on the f drive that crashed.) Went through it once and did not notice a path and uninstalled it. Read some stuff online and if only the launcher is on the c drive I was fine with. So went through the installed again and got that error. Sorry I did not type that up first.

It does not show in the control panel but I think something is still on here. I am running updates just in case something is not install. I am trying to avoid to install windows over itself right now as I have some projects due in a couple of days and I would not be able to get to install windows over itself til the end of the week. This is win 7 64 just if that makes any difference.
Thanks again James

avatar image 0xDEADBEEF STAFF May 30 '15 at 12:03 AM

If you don't see an entry to uninstall in "Add Remove Programs" then most likely one/some of the registry keys windows installer uses to see if a product is installed is still hanging around. I recall discussing the topic with users in a few posts. I'll try to find the threads.

avatar image 0xDEADBEEF STAFF Jun 05 '15 at 07:47 PM

Sorry for the delay, the threads I mentioned were not as helpful as I recalled: Ex: Link

I'm in the process of trying to figure out what registry entries might be causing Windows Installer to reference a previous launcher install when no launcher program entry exists in Cointrol Panel->Remove Programs.

In the mean time, you could try the Microsoft Fix It utility(select problem with uninstalling and see if you can find the launcher in the applicaiton list): https://support.microsoft.com/en-us/mats/program_install_and_uninstall

avatar image Shadow_1138 Jun 06 '15 at 08:10 PM

Ok, sorry it been a bit, went through the registry and took out keys for epic and unreal and getting the same issue. is there a place where I can get a list of all the registry keys and all files that get installed?

Thanks again James

avatar image 0xDEADBEEF STAFF Jun 08 '15 at 06:29 PM

Did you get a chance to try the Fix It utility?

The registry entries that are causing you issues are most likely created by Windows Installer itself. Chances are they don't have epic/unreal info in their key and use some GUID identifier that may need to be cross referenced with data/values of other registry entries. These will be the types of entries Windows Installer adds for any app it tries to install. These might be well known registry entries but I don't have a list of them at the moment. I'm trying to compile that list but that involves pouring over all the Windows Installer docs and info I can get my hands on.

avatar image Shadow_1138 Jun 12 '15 at 12:21 AM

I have ran the fix it utility from MS, also I ran Revo Uninstaller to see if that picked up anything.

Thanks again James

avatar image 0xDEADBEEF STAFF Jun 12 '15 at 03:16 AM

Did either one help in this case?

avatar image Shadow_1138 Jun 12 '15 at 10:08 PM

Unfortunately I am getting the same error, do you have any other ideas? Also please let me know when you get that registry list.

Thanks again James

avatar image 0xDEADBEEF STAFF Jun 19 '15 at 02:42 AM

Sorry for the delay, have not been able to track down good sources for the info we are after. IT is setting up a windows VM for me so I can run some test installs in a clean environment. Should have some info shortly.

avatar image Shadow_1138 Jun 23 '15 at 09:08 PM

Thanks again James

avatar image Danny_Field Jan 16 '16 at 03:46 AM

Had the same issue with changing drive letters - couldn't install nor remove as I didn't have drive G anymore. So for Windows 10 64bit, the above answer didn't work. Again, backup your reg before deleting.

HKEY_CLASSES_ROOT\Installer\Products\

Unfortunately you'll need to go through folder to find the entry [Or you could simply search for 'UnrealEngineLauncher']

You should see :

Production : C:\WINDOWS\Installer{A1C97AE7-FB6B-425F-B75B-7A16E1E5639D}\UnrealEngineLauncher.ico You're string will be different, but you should be looking for UnrealEngineLauncher.ico

I tried to follow 0xDEADBEEF's tutorial, but couldn't find the same 'string' in the Uninstall. So I figure, it's not working, so I'll delete the entry in the HKEY_CLASSES_ROOT\Installer\Products_a lot of letters and numbers_

Deleted, and tried to install UE4 again, and it worked. Was able to install it to a new location. Just prior to this, it would say "Can't find Drive G".

The 'UpgradeCode' did have the 44F9670D954DF0540B48AC3E08267CB5 entry in it, but it was only strings. It may have been because I had tried to remove it. I actually deleted preferences before hand - which may not have been needed. But in the end, the new UE4 now works on a different drive letter.

Hope this helps.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Again, sorry for the delay. I never got my VM setup but I was able to do some additional digging on my dev machine. I grabbed a program called Orca, which comes with Windows SDK Components for Windows Installer Developers. With this program I got to look inside the msi and learn more than we ever wanted to know about it :) I'll skip over the boring details, but with the info I pulled from Orca I was able to decipher the various registry keys that Windows Installer will use to store stuff for the installer referenced in your error dialog.

Before you do anything with the registry, please make a backup of it. You can do this in regedit by selecting the File->Export option.

To manually remove Epic Games Launcher registry keys added by the installer mentioned in your dialog you would do the following.

  • Open Regedit and Backup your registry

  • Navigate to the following registry entry and find the ProductIcon field: HKEY_CLASSES_ROOT\Installer\UpgradeCodes\44F9670D954DF0540B48AC3E08267CB5

  • Write down or copy the GUID that appears in the ProductIcon path, we will need it later. The path looks something like this:C:\Windows\Installer\ {38F69744-A2C5-4913-813B-7001D6CDC130}\UnrealEngineLauncher.ico. We are interested in the bold part of the path(Your GUID will be different than the one on my machine).

  • Once you copy the GUID from step 3, delete the following registry entries.

    HKEY_CLASSES_ROOT\Installer\UpgradeCodes\44F9670D954DF0540B48AC3E08267CB5 HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\UpgradeCodes\44F9670D954DF0540B48AC3E08267CB5 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UpgradeCodes\44F9670D954DF0540B48AC3E08267CB5 HKEY_CLASSES_ROOT\Installer\Features\44796F835C2A319418B307106DDC1C03 HKEY_CLASSES_ROOT\Installer\Products\44796F835C2A319418B307106DDC1C03 HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Features\44796F835C2A319418B307106DDC1C03 HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products\44796F835C2A319418B307106DDC1C03 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\44796F835C2A319418B307106DDC1C03

  • Now navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall and find the entry that matches the GUID you wrote down in step 3. Delete this entry. In my example I would delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\ {38F69744-A2C5-4913-813B-7001D6CDC130}

After all that you should be able to use the new installer you have. Hopefully I didn't miss anything. Let me know how it goes.

more ▼

answered Jul 07 '15 at 03:08 AM

avatar image

0xDEADBEEF STAFF
1.5k 18 12 47

avatar image Shadow_1138 Jul 07 '15 at 09:19 PM

Thank you so much for all your time and effort. This worked.

Thank you again James

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question