x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Event Begin Play in Always Loaded Streaming Level

Hello,

I have an actor which uses Event Begin Play in its BP. It works perfectly well if placed in Persistent Level but in Streaming Levels it works only if their streaming method is set to "Blueprint" - I enter Level Streaming Volume and then the event starts. If streaming method is set to Always Loaded then Event Begin Play starts only if Level Streaming Volume is visited second time. Probably because exiting it for the first time unloads the level. But is it correct behaviour? Shouldn't the event start with the beginning of the Persistent Level if it's always loaded?

Product Version: UE 4.7
Tags:
more ▼

asked May 29 '15 at 06:42 PM in Bug Reports

avatar image

Nox_A15
309 19 138 194

avatar image CyberblastSoft Feb 21 '17 at 09:32 PM

I am having this issue as well in 4.15. I am using Use Client Side Streaming with volumes in the world settings, only on the second time and beyond are the BeginPlay and Tick functions called. Is this intended behavior Epic?

avatar image Ghostblades Apr 17 '17 at 07:23 AM

I am also starting to see this happening - it seems that if I use my Level BP to call a custom event after the streaming map has been loaded it works I have been using this as a work-around but a lot of my BPs have problems with event begin play - with streaming levels as well guessing this is some kind of bug then?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey CyberblastSoft,

Would you mind providing me with some more information regarding your setup? If you have a set of steps I can follow to reproduce this in 4.15 that'd be great.

I just created an always loaded sublevel, and on its begin play I printed a string, and it seemed to work fine. It's possible I'm overlooking a few things though so I'd like to see how you've set it up on your end.

Thanks

more ▼

answered Feb 22 '17 at 03:02 PM

avatar image

Sean L ♦♦ STAFF
43.5k 485 152 442

avatar image CyberblastSoft Apr 09 '17 at 12:03 AM

I apologize that I have not gotten back to you! We are using the setting in the world settings for Use Client Side Streaming Volumes. And we are also using the Always Loaded setting on each of the streaming levels. Once the Client steps into the volume the first time, all of the actors and the level blueprint of the streaming level do not get their beginplays called. This only happens the first time. Evey other time, they it works just fine.

avatar image Sean L ♦♦ STAFF Apr 12 '17 at 05:17 PM

Sorry for the delay. I believe the issue you're running into is something that I logged the other day: https://issues.unrealengine.com/issue/UE-43879

Note that the ticket refers to Tick, but it also has been confirmed with BeginPlay as well.

Have a great day

avatar image DocQS Apr 20 '17 at 01:18 AM

Hello Sean,

I was wondering if any solution has been discovered to this yet. I have been having trouble with both tick and begin play for a while. Is there an expectation to when this might be resolved? Sorry if my question is ridiculous.

Thanks, DocQS

avatar image Sean L ♦♦ STAFF Apr 21 '17 at 01:21 PM

Please refer to the link posted above to the public tracker. It will be updated as soon as a fix is available.

Have a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question