x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Linux 4.8 Bugs

Some linux bugs from 4.8

  1. When importing FBX, uv's do not import correctly. It re-scales the mesh uv's to fit between 0-1.

  2. Overwriting a fbx doesn't actually overwrite the vertex colors (drag and drop a file from file browser and it asks to overwrite, but doesnt completely overwrite)

  3. Delete keyboard shortcut doesnt work in the editor

Product Version: UE 4.8 Preview
Tags:
more ▼

asked Jun 01 '15 at 11:46 AM in Bug Reports

avatar image

Gibbz
61 5 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hey Gibbz-

After checking on a different version of the engine I too saw the same behavior and entered a bug for the lightmap generation (UE-16516).

Cheers

Doug Wilson

more ▼

answered Jun 03 '15 at 02:55 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey Gibbz-

I checked the the delete key functionality and found that this has already been reported (UE-14143). I'll need more information to understand the other issues. For the first one (FBX uv's) can you explain what you're doing and what you're seeing when importing the FBX. I tried importing a FBX who's unwrap is outside the 0 - 1 space. UV channel 0 maintains the unwrap as imported from the modeling program (3DS Max in this case). Below are the settings used during import as well as what my UV's look like in the editor. Let me know if you're seeing something different or if my process was different.

alt text

alt text

Cheers

Doug Wilson

fbxuvs.png (699.3 kB)
more ▼

answered Jun 01 '15 at 05:40 PM

avatar image Gibbz Jun 02 '15 at 02:52 AM

Ok, think ive figured out whats going on.

  1. On windows the default import setting was to overwrite vertex colors, on linux its set to ignore. Shouldnt this always just be replace as default? alt text

  2. When I import using "Generate Lightmaps UV's" which is default, it overwrites my channel 0 uv's. I have tested this on windows with the same file and it works fine, so this looks like a linux only bug. alt text

And with lightmap disabled it works... alt text

  1. Also noticed the Project browser does not remember/save the projects that are outside of the default unreal projects path, which is a bit of a nuisance (same on windows if i recall).

  2. And that flashing tutorial button top right! Will that ever be fixed! :D

avatar image RCL STAFF Jun 29 '15 at 08:34 PM

FWIW BaseEditorPerProjectUserSettings.ini has Ignore as a default vertex color import option on all platforms. Could it be that you changed this on Windows in the past and it got saved with your preferences?

avatar image Gibbz Jun 02 '15 at 04:15 AM

also noticed changing objects between levels via the "world outliner" doesnt seem to work on linux. Right click > level > move selection to current level. The mesh disappears from both levels into who know where...

avatar image Doug E ♦♦ STAFF Jun 02 '15 at 01:39 PM

Hey Gibbz-

I've tried changing my settings as you suggested and the UV's for my mesh are still appearing as in the screenshot I posted before. Additionally, when you have "Generate Lightmap UVs" checked true it should produce the lightmap as UV Channel 1. Based on the screenshots you provided I don't see Channel 1 in either case which is strange. If possible could you send the asset that isn't importing correctly?

avatar image Gibbz Jun 03 '15 at 01:05 AM

Yep, thats whats happening, the generated uv is overwriting my channel 0 with the lightmap. Hence its losing my uv data. link text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Yep, thats whats happening, the generated uv is overwriting my channel 0 with the lightmap. Hence its losing my uv data.

link text

more ▼

answered Jun 03 '15 at 01:03 AM

avatar image

Gibbz
61 5 9 15

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question