x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

UE4 throwing error "No compiler was found..."

The full error is "No compiler was found. In order to use a C++ template, you must first install Visual Studio 2013," there is an image attached. Although I already have Visual Studio 2013 installed. I've looked at multiple threads that are asking the same question, but none of the answers have worked for me. I already have set my environment variable "VS120COMNTOOLS" to "C:\Program Files(x86)\Microsoft Visual Studio 12.0\Common7\Tools\"

In case you are wondering why I am using the older version of UE4, 4.1.2, it is because I thought that it would resolve my errors with Visual Studio in 4.7.6.

My system specs, if needed are: Graphics Card- NVIDIA GeForce GTX 750

RAM- 16GB

Processor- Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz

OS- Windows 8.1

UE4 version- 4.1.2

Product Version: UE older version
Tags:
capture.jpg (88.1 kB)
more ▼

asked Jun 02 '15 at 12:07 AM in Installation & Setup

avatar image

CoolKidsOnly
1 1 2 2

avatar image Doug E ♦♦ STAFF Jun 02 '15 at 03:37 PM

Hey CoolKidsOnly-

Do you receive the same error warning when trying to create a code project in another engine version? If so you may want to try reinstalling VS. Also, what errors are you getting with VS in 4.7.6?

Cheers

Doug Wilson

avatar image CoolKidsOnly Jun 02 '15 at 07:35 PM

When I try to create a C++ file in version 4.7.6, it would come up with a similar error, but after all the code was built, the engine would say build failed, open with Visual Studio.

When I went into a project with 4.7.6 (basic and blueprint,) the button located at file->add code to project was not grayed out, although when I clicked on it, it would not let me create a class.

When I am in 4.1.2 after launching it through a blueprint basic project, the file->add code to project is grayed out.

I have re-installed both the engine and Visual Studio 2013 multiple times.

avatar image Doug E ♦♦ STAFF Jun 03 '15 at 03:29 PM

Do you have multiple versions of Visual Studio on your computer? If so remove all but 2013 and try again. Additionally you may want to install VS on your C: drive if it is not.

avatar image CoolKidsOnly Jun 03 '15 at 06:36 PM

Ok, will do.

avatar image Tim C ♦♦ STAFF Jun 10 '15 at 07:56 PM

Hi CoolKidsOnly,

I just wanted to check and see if you still need any help with this issue. Were you able to get everything working after trying Doug's suggestions?

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi CoolKidsOnly,

We haven't heard from you in a while. Were you able to solve your issue? If so, please share how you were able to resolve it for future users. In the meantime, I'll be setting this issue to resolved for tracking purposes. If you still require assistance, please feel free to comment and the question will reopen.

Have a nice day

Matthew Clark

more ▼

answered Jun 16 '15 at 09:51 PM

avatar image RatBoiToy Feb 08 '17 at 04:48 AM

I have the same problem. I didn't have VS and then I downloaded it when I was making a new c++ class. So I waited and then refreshed, but it was still saying there was no compiler.

avatar image Matthew J Feb 08 '17 at 03:00 PM

Have you tried restarting your computer since installing Visual Studio? What version of Visual Studio did you install? What version of the editor are you using? Do you get exactly the same message saying that there is no compiler found or do you get something else?

avatar image RatBoiToy Feb 08 '17 at 03:19 PM

I downloaded vs 2015, I am using ue 4.14.3 and I did get the same error. I didn't try restarting though.

avatar image Matthew J Feb 14 '17 at 10:16 PM

Have you tried restarting to see if that helped?

avatar image Hyperion Rising Mar 27 '17 at 03:31 PM

Hello, I am having the same error, except on UE4 4.15 and with VS 2017 freshly installed. Was a fix ever determined?

avatar image Matthew J Mar 27 '17 at 06:56 PM

Hello Hyperion Rising,

RatBoiToy never came back so I'm not sure if he was able to resolve his issue. If you're using 2017, have you selected Visual Studio 2017 in your project settings under Platform > Window > Toolchain > Compiler Version?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question