x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

How to fix artifacts?

So Im going from Zbrush to the engine and my mesh seems to be fine. Although, when I am importing into the engine I am getting some small artifacts that you can see as well as being able to see some polys. This is when I import as a static mesh. Jpg

For some reason some of these artifacts go away when I import as a skeletal mesh and I can no longer see the revealing polys. jpg2

I use Zremesher to retopo my mesh and use the "Check Mesh" and "Fix Mesh" tools but there isn't any bad geometry. I also use UV Master in Zbrush to create a UV map and export both the mesh and map through multimap exporter. I turn Generate UV map off when importing and yet I still get these artifacts. I know I should Retopo and create a UV Map myself but my mesh is very intricate with many parts (you only see one in the photos) and I am going to creating many of these types of meshes so I would rather take the quicker route and apply a fix. Sorry for my stubbornness and thank you in advance.

Product Version: UE 4.7
Tags:
bug2.jpg (364.1 kB)
bug1.jpg (329.6 kB)
more ▼

asked Jun 02 '15 at 03:02 AM in Rendering

avatar image

Deathcheater
18 2 5 7

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Make sure Unreal isn't recomputing normals. There should be a checkbox in the static mesh editor that is normal on by default.

more ▼

answered Jan 31 '19 at 04:59 PM

avatar image

Rokasana
21 3 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question