x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Prevent Camera from going through walls

I been working on UE4 today and i noticed that my camera goes through my bsp wall. I tried adjusting the camera and using camera blocking volume and nothing works. I would appreciate it if someone help me with this problem. I posted a image showing the problem.alt text

Product Version: UE 4.7
Tags:
more ▼

asked Jun 02 '15 at 11:14 PM in Rendering

avatar image

Winter Wolf
6 2 3 3

avatar image Tim Hobson ♦♦ STAFF Jun 03 '15 at 09:27 PM

Hi Winter Wolf,

How do you have your camera in your player character BP setup? Are you using a spring arm for the camera?

You may want to look at the settings that are in the spring arm in the Third Person Template project. This can help you troubleshoot what may not be setup in your current project.

Let me know if that works out.

Tim

avatar image Winter Wolf Jun 04 '15 at 11:46 PM

i tried that but everything is the same

avatar image Theololz Oct 04 '15 at 09:43 PM

bump. I have the same problem but only when standing infront of a wall and switching my camera position to be closer to the character. How can one prevent this?

avatar image Smomo Oct 08 '15 at 03:37 PM

the collision setting of the wall should "Block Camera".

avatar image Smomo Oct 08 '15 at 03:40 PM

alt text

1.png (31.3 kB)
avatar image JacobPresley Feb 01 '16 at 09:40 PM

Make sure you move your camera in the player view port to be touching the arm. This is what fixed it for me. If you need to make the camera move backwards adjust the arm length of the spring arm.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Hey all,

By default the Third Person Character Blueprint will have this option enabled. In case you accidentally disable it, make sure you have selected the 'Camera Boom' component. Then within the details panel you can select 'Do Collision Test'.

Camera Boom Collision Test

alt text

As the tooltip suggests, this will prevent your camera from clipping into the level. Let me know if you have further questions. If the image appears too small, you can right click and open in a new window or tab to see the original full size.

Cheers,

Andrew Hurley

more ▼

answered Feb 02 '16 at 08:02 PM

avatar image IronBoundManzer Feb 08 '17 at 06:00 AM

This does not work man ! I'm tired now of trying. I have a CameraBoom, I have turned on Collision Test. Yet my camera goes through everything ! I have implemented Rotation of camera, zoom in and out. idk if that makes anything different.

avatar image MonsOlympus Feb 08 '17 at 01:00 PM

Have you made your own question about this? If you lay out your implementation I could take a look and see if your zoom or something else is causing issues.

avatar image AndrewHurley Feb 08 '17 at 04:00 PM

I agree, since this issue is over a year old and we do not have any context as to your setup, then we would need that laid out first before we can assist you.

Please make a new AnswerHub post addressing your specific issue and provide us with steps to reproduce it on our end.

Thank you,

Andrew Hurley

(comments are locked)
10|2000 characters needed characters left

Spring arms never worked as intended and they never will as i discovered trough many many threads. It is a common UE issue that is carrying all over and one of the most importants issues people encounter when making NON first person based games. No matter what you try, you will always get clipping, even if the spring arm is supossed to mitigate it, this is completely obvious using a third person template when you rotate the camera. In first person shooters is not really noticeable because the camera is basically snapped to your character. The only option that could work in the case of a third person template is to make the walls and other objects thicker, so the probe cant pass through the object. But thats about it. Im still, after so many years waiting for Epic to actually fix and improve the spring arm system so we can actually make decent third person games. Still no luck. Thats the main reason i NEVER EVER start a third person project. Its completely annoying and unacceptable. In the cases when you will walk over a building, and using doors and small apertures, its going to be a total mess. And it looks terrible. Unfortunately UE is designed for first person shooters and no much more, sadly.

more ▼

answered Dec 10 '17 at 04:33 AM

avatar image

amstradcpcuser
6 3 9 10

(comments are locked)
10|2000 characters needed characters left

Ok so I'm like super late to this thread but it looks like this wasn't resolved, I had it myself and I think i know how to fix it. When I added my own spring arm and attached the camera to it I adjusted the camera with the cameras parameters. This is what caused the issue because the end of the red line shown when the spring arm is selected is where its going to spawn the probe to test for wall collisions. To fix this reset the transform data on the camera itself and adjust the camera via the camera boom settings.alt text

alt text

capture.png (271.6 kB)
capture2.png (22.1 kB)
more ▼

answered May 03 '18 at 11:08 PM

avatar image

trufanandrew
1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question