x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android(5.1.1) Nexus 10 game launches with black screen.

My project builds fine, I use the project launcher and I've tried ETC1 and ETC2. when the tablet picks it up it starts to a black screen. It stays there now, eventually it pops up a message that says "project has stopped working", this takes several minutes before that pops up. I went into the project settings and used the target hardware tab, set the platform to mobile/ tablet, and set the second option to "scalable 3D or 2D", this brought up pending changes which looked like all the goodies were getting turned off (bloom, HDR lighting, etc..). I applied those settings and rebuilt the project. My ue4 build is 4.7.6. I've followed the hello Android documentation and various other posts. I've come across posts suggesting it's due to my default map not being set but I've verified that my start map is "Example_Map" (I've not renamed it yet ;) ). My scene has one directional light in it. I believe there are 3 objects, totaling probably 1000 triangles. I have no actual textures being used. Just materials with color fills.

Any Ideas?

Product Version: UE 4.7
Tags:
more ▼

asked Jun 03 '15 at 03:39 PM in Packaging & Deployment

avatar image

Thumper
966 143 150 390

avatar image Thumper Jun 03 '15 at 07:17 PM

Okay, I've tried creating a blank project, setting the project as mobile/ tablet, and 3D or 2D upscaling, disabling HDR, bloom etc... No starter content, just the startup grid floor with player spawn, sky box, and light. The build fails this way.

 Program.Main: ERROR: Exception in UnrealBuildTool: ERROR: Can't make an APK without the compiled .so [C:\Users\Heath\Documents\GitHub\UnrealEngine-4.7\Engine\Binaries\Android\UE4Game-armv7-es2.so]

 Program.Main: ERROR: ERROR: Can't make an APK without the compiled .so [C:\Users\Heath\Documents\GitHub\UnrealEngine-4.7\Engine\Binaries\Android\UE4Game-armv7-es2.so]

 RunUAT.bat ERROR: AutomationTool was unable to run successfully.


avatar image wittlief ♦♦ STAFF Jun 03 '15 at 07:42 PM

Hi Thumper,

Please have a look at this forums thread wherein the user had the same build failure. The immediately following post is how to solve it.

Good luck!

avatar image Thumper Jun 04 '15 at 01:08 PM

That's true for the second comment where I started a blank project. This project contained no code so I never had to compile the project. Adding code and then compiling - compiles the project.so (I believe). I'm still running into the same problem for my first comment. My project is pretty bare bones. I've not a complex scene, probably around 1000 polygons, not textures, just materials with color fills. I've targeted the project for mobile and scalable 3D or 2D which downgrades all the settings for tablet/ mobile - I applied those settings being turned off. My project builds fine, deploys to the tablet, but my screen remains black. I've read that this means the default map isn't set, but I've verified that the map I want to load (my scene) is set to the default and startup map.

avatar image Thumper Jun 04 '15 at 01:15 PM

Actually I'm curious, is anyone getting working builds on the nexus 10? I understand there is a range of compatibility so maybe it's a problem with that? I'm not sure what else I can turn off or disable at this point. The scene is as basic as a test could be. A ground, and a player start, with one light.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Okay I've gone back to UE4 4.7.6. I've started a new blank code project, with mobile/ tablet, and scalable 3D or 2D. I upgraded to the tadp-3.0r4 (This must have been the trick). I rebuilt my project (from visual studio). Now when I start the game (with default map set to my level) the game starts to a black screen for a couple minutes (while I can see UE4 on the fly window is still doing stuff) then...Bam! it loads! The little analog controller huds are on the bottom left and right, and I can everything I'm supposed to + move around (awesome).

more ▼

answered Jun 04 '15 at 08:21 PM

avatar image

Thumper
966 143 150 390

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question