x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[BUG] Install script for installing Android APK and OBB fails

I'm using the 4.8.0 Preview 4 on OS X. I successfully built an Android APK with the game files in an OBB file. But when I run the installation script, it fails.

After some tinkering, it looks like the issue is that I had a space in the field pathway to the Android SDK on my computer. I updated the field pathway to have underscores "_" and updated the file pathway in the script, which removed the issue of not finding the SDK in the script.

But there was still a syntax error with the parentheses on line 33 of the script. Adding the backslash "\" escape character before the parentheses fixed the issue.

But it still won't install.

Here is the script file (zipped so it'd upload): link text

Here is the output from the terminal:

 Last login: Thu Jun  4 22:34:31 on ttys000
 /Users/jonathandaley/Documents/Unreal\ Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command ; exit;
 My-MacBook-Pro-2:~ jonathandaley$ /Users/jonathandaley/Documents/Unreal\ Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command ; exit;
 /Users/jonathandaley/Documents/Unreal Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command: line 4: SDK/adt-bundle-mac-x86_64-20130514/sdk/platform-tools: No such file or directory
 
 Uninstalling existing application. Failures here can almost always be ignored.
 /Users/jonathandaley/Documents/Unreal Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command: line 9: uninstall: command not found
 
 Installing existing application. Failures here indicate a problem with the device (connection or storage permissions) and are fatal.
 usage: install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
                [-o owner] file1 file2
        install [-bCcpSsv] [-B suffix] [-f flags] [-g group] [-m mode]
                [-o owner] file1 ... fileN directory
        install -d [-v] [-g group] [-m mode] [-o owner] directory ...
 
 There was an error installing the game or the obb file. Look above for more info.
 
 Things to try:
 /Users/jonathandaley/Documents/Unreal Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command: line 33: syntax error near unexpected token `('
 /Users/jonathandaley/Documents/Unreal Projects/Android_ATC/Install_TestAndroidProj_Development-armv7-es2.command: line 33: `echo Check that the device (and only the device) is listed with \"$ADB devices\" from a command prompt.'
 logout
 
 [Process completed]
 


Product Version: UE 4.8 Preview
Tags:
more ▼

asked Jun 05 '15 at 03:25 AM in Bug Reports

avatar image

JonathanADaley
644 37 49 77

avatar image wittlief ♦♦ STAFF Jun 08 '15 at 05:17 PM

Hi JonathanADaley,

When you say 'installation script' is this one you have created yourself, or the batch file that is created in packaging? Do you get the same error when you attempt to install the .apk with the batch file that is created when you package?

avatar image JonathanADaley Jun 08 '15 at 08:57 PM

This happens with the batch file that is generated when packaging.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

It looks like you might have your environment variable for ANDROID_HOME set to the wrong path. Set this to the directory where you installed the Android SDK or the sdk directory if you installed Android Development Tools. It must contain a directory called platform-tools. Here is a Stack Overflow thread that has clear Mac instructions.

Good luck!

more ▼

answered Jun 09 '15 at 08:09 PM

avatar image JonathanADaley Jun 28 '15 at 04:37 AM

Just a quick update; I wasn't able to get the install script working on OS X, but it does work on Windows.

I used the NVIDIA TADP to install everything on Windows, but didn't on OS X (I had installed SDKs using Eclipse several years ago, then updated SDKs with Android Studio, and then installed what was missing for UE4 (NDK, ANT, etc.) using the TADP).

I probably just missed something on OS X. But at least it's working on Windows.

avatar image wittlief ♦♦ STAFF Jun 29 '15 at 02:38 PM

Yeah, the piecemeal SDKs probably has something to do with it, especially if you're using source and being required to compile for Android to package.

Unfortunately, we're in kind of a weird place with Android SDKs.TADP isn't a thing anymore, it is now AndroidWorks. You can get by with installing the version of TADP that is included with UE4 onto your Mac; it's a pretty old version. Getting support for AndroidWorks is a top priority but I am not 100% sure it's going to happen prior to the 4.9 release. If packaging for Mac is a priority for you right now, I'd install the TADP that comes with UE4.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question