x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

crash when reparenting blueprint

Trying to re-parent a blueprint causes a crash.

Product Version: UE 4.8 Preview
Tags:
more ▼

asked Jun 05 '15 at 02:04 PM in Bug Reports

avatar image

StevePeters
38 6 11 14

avatar image Ben Halliday STAFF Jun 05 '15 at 03:53 PM

Hi electricsauce,

Can you give us some more information for this crash? What type of Blueprint are you trying to reparent, or does it occur with any Blueprint? Does this happen in a new project for you as well as your current project?

Please also zip and attach the log from your project after this crash occurs. It can be found in your project's Saved\Logs folder. Thanks!

avatar image StevePeters Jun 05 '15 at 05:23 PM

link text

It seems to work now. Basically I modified a parent blueprint class ( I added a boolean variable) which caused line trace errors and a few other unidentifiable node issues. Recompiling and refreshing the nodes doesn't seem to help, but reparenting the BP to the actor class then reparenting it back to it's original parent class seems to fix the issue.

The blueprints I'm working on use the beta version of the procedural mesh actor. When I tried to reproduce the crash to generate the log for you it worked as expected. The logs I've attached may have information related to the previous crashes but I'm unsure of how to interpret the data.

logs.zip (2.3 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Thanks for the logs! It looks like we have a report in our system for this already (UE-14733), but we're still not sure what causes it. The first thought was that it was a corrupted file, but that wouldn't make sense if it suddenly started working for you again. I've added your information, but if it's working for you now there's not much I can get. If it starts happening again, please zip up the project and upload it somewhere I can access and send me a link so we can look it over, maybe find the cause. Until then, I'll go ahead and resolve this issue. Thanks!

more ▼

answered Jun 08 '15 at 06:57 PM

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question