x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fmod in Unreal: Sounds work in editor but not in packaged build

I have Studio working like a dream within the UE4 editor, even in Standalone - but when I create a package, none of the FMod audio plays.

Could this be to do with missing data or something when it creates the package? or missing .dll files?

Pulling my hair out - no errors when the package runs, just no Fmod sounds playing.

Anyone able to offer any wisdom?

UE4.7.6 Fmod Studio 1.06.03

Trying this with both a 2d and 3d sound.

Thanks

-a

Product Version: UE 4.7
Tags:
more ▼

asked Jun 09 '15 at 04:29 PM in Using UE4

avatar image

AlanMcDermott
6 1 3 5

avatar image gbsr Jul 21 '15 at 10:56 PM

Same problem here, still haven't figured out why.

avatar image Kyoril Aug 12 '15 at 11:40 PM

I'm using a custom version of 4.8.3 (with some NVIDIA Tech added), and it works out of the box. However, I have a slightly different problem, which (at the first look) seems to be the same:

Only SOME sounds don't play in the packaged build, others do. In the editor however, ALL FMOD Sounds are working.

Just a little tip: In the latest FMOD version (1.06.07), you have to add the FMOD folder with your sound bank to the Content directory of the packaged build (not in the .pak files). So if your game is named "Test" and the directory you choosed to package to is named "C:\Package" then you will have something like this:

C:\Package\WindowsNoEditor\Test.exe C:\Package\WindowsNoEditor\Engine... C:\Package\WindowsNoEditor\Test\Content\FMOD\Desktop\Master Bank.bank

This is where you have to put your FMOD folder in to. Hope this helps. However, this doesn't solve my problem :)

avatar image ThomSip Dec 08 '15 at 02:41 PM

^THIS

Thank you, fixed my problem. Really weird workflow IMO. (Packaging a game first and adding the sounds later, saaywuut?)

But it works. so thank you

avatar image TornadoTwins Feb 18 '16 at 04:31 PM

I had the same problem, and indeed, copying the FMOD folder into the Contents folder solved the issue. Odd that the packager doesn't copy the files for you. But at least, it's solved now. That's a huge relief.

avatar image LemonInGintonic Nov 21 '15 at 08:47 AM

Does it work if you change build configuraton?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

You can run the "FMOD Validate" option in the UE4 Help menu for a one-button fix. I had a similar problem. source: http://www.fmod.org/documentation/#content/generated/engine_ue4/getting_started.html

more ▼

answered Jun 13 '17 at 02:02 AM

avatar image

MattWoelk
37 4 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question