x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Orange marks on mesh after building lighting

Hi there !

I got a strange problem when building lighting in Unreal 4 After rendering I get this oranges marks on my meshes and I don't know how make them disapear...

Anyone has an idea ?alt text

Product Version: UE 4.7
Tags:
orange_marks.jpg (304.1 kB)
more ▼

asked Jun 10 '15 at 03:03 PM in Rendering

avatar image

Grimmaldi
28 2 3 3

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hi Grimmaldi,

I can see the orange marks on your mesh, but that's not enough information to necessarily go by.

  • Can you tell me what type of lighting you're using in your scene? Static/Stationary/Movable

  • If you're using Static/Stationary, can you show me a layout for your meshes Lightmap UV that is causing the issue?

  • Is this multiple meshes or a single mesh that is causing the issue?

  • What is your Lightmap Resolution set to? If it's the default 32 or 64 can you increase it to 128 or 256 and build lighting. You may need to go higher depending on the UV layout for the lightmap and how large the overall mesh is.

I'm happy to help, but I will need to know the information above to better diagnose and offer tips for your lighting,

Thank you!

Tim

more ▼

answered Jun 10 '15 at 03:55 PM

avatar image

Tim Hobson ♦♦ STAFF
48.9k 887 101 876

avatar image Grimmaldi Jun 10 '15 at 04:15 PM

Hi Tim !

Thanks for your help !

First, I'm using only stationnary lights.

Sorry for my english, i'm french but what is a layout for my meshes ? Do you want to see the lightmap of the mesh ?

I got the same problem on other meshes. As you can see there : alt text

This lightmap mesh is set on 1024. My project is a house, so i decided to set up the lightmaps on the walls a bit higher.

Oh and i tried just changing the lighting setup from "Preview" to "Medium" to start, and it didn't change anything...

Thanks you very much for you help ! Hope my post is not too... blured... by my english !

orange_marks02.jpg (320.4 kB)
avatar image Tim Hobson ♦♦ STAFF Jun 11 '15 at 03:34 PM

No worries. Your english is perfectly fine. :)

Do you want to see the lightmap of the mesh ?

Yes this would possibly help see what's going on.

  • Did you create the lightmaps yourself in your modeling application or did you use the generated lightmaps that UE4 can create?

  • Also, if you were to create a test map with just one of the troublesome assets like the image above and build lighting do you see the same issues? This can maybe help narrow down what may be happening.

avatar image Grimmaldi Jun 12 '15 at 08:26 AM

Hey Tim, thanks for you answer ! (And for being comprehensive with my english skills)

Here are lightmaps of my mesh, I created them manually in 3Dsmax, i've got no errors when building the lights, so i thinks they're ok.

I test your idea and created a new map, and there was no problems like this ! So I think it might be some parameters in my scene or something like this ?

Anyway, hope you will have some more ideas, I hope we're getting closer, at least thank you so much for you help !

Louis.

alt text

alt text

orange_marks03.jpg (293.7 kB)
orange_marks04.jpg (238.3 kB)
avatar image Grimmaldi Jun 12 '15 at 10:35 AM

Just wanted to add, I tried adding a light next to the mesh to see if it was a problem with my lights in the scene and if the problem disapeared with this... But no, mesh is of course more lighted but i still have theses marks on it !

avatar image Tim Hobson ♦♦ STAFF Jun 17 '15 at 09:46 PM

Hey, sorry for the delay, I've had some higher priority things coming in lately.

Are you still getting this in error? If so, would you be willing to share one of the meshes and I can test on my end to see if I can narrow down what is going on. If you're willing you can post a link here or send me a link via the forums here: https://forums.unrealengine.com/private.php?do=newpm&u=4894

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question