x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Particles look blurred

Hi,

somehow my particles are not as sharp looking as they should be. Within cascade everything looks nice and sharp, ingame however, my particles are blurry. Is it some kind of LOD problem? My particle system has only one lod, so it shouldn't be..

Here is a screenshot for better understanding: alt text

I'm sure there must be an easy solution, some kind of settings i missed... I hope you can help me out!

Cheers

Product Version: UE 4.7
Tags:
more ▼

asked Jun 10 '15 at 03:34 PM in Rendering

avatar image

Priareos
183 22 26 35

avatar image Lovecraft_K ♦♦ STAFF Jun 10 '15 at 05:30 PM

Hi Priareos -

It looks like the Mesh Emitter that generates your dome effect is trying to reflect lighting in the scene. Check the material used for that mesh and see if it is default lit and if there is a roughness setting inputted into it. I would set it to unlit and set a roughness of 1.

Let me know if that doesn't fix the issue for you -

Eric Ketchum

avatar image Priareos Jun 10 '15 at 05:52 PM

Hi Eric,

Thx for the fast reply.

My Dome consists of two emitters, a black one (default lit, translucent) and an orange one (unlit, additive). The orange one does have some dissolve stuff going on inside, but i don't think its cause for the issue. Just in case i attached the material. alt text

I tried turning off the black, lit, one, didn't change anything.

Cheers

avatar image Lovecraft_K ♦♦ STAFF Jun 10 '15 at 08:46 PM

Hi -

I ran a quick test using your material above, and I think it might be your texture which is causing the issue (not the Dissolve Texture). If you remove it from the setup are you still seeing the same problem?

Thank You

Eric Ketchum

avatar image Priareos Jun 10 '15 at 10:53 PM

Unfortunately it looks exactly the same -.- I disconnected the texture completely and nothing changed at all. Cascade preview crystalclear, ingame blurred.

Thank you for your effort! Any other ideas?

Cheers

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi -

Okay in your Project, make a new Empty Level (the one with Black nothingness) Add the Particle System to the new empty level and while the emitter is selected press the "?" key on your keyboard. This will fire off the effect, does it look like it is still not fully translucent.

If it does please take a screenshot and let me see what it looks like with nothing in the background. Chances are though that it looks like it does in the Particle System viewport. If that is the case, then you will need to either adjust the Material to not be Additive but straight Translucent, adjust the color and roughness of the level underneath the effector adjust the Post Process Settings in your level. The Additive behavior is causing what appears to be a not transparent effect.

Thank You

Eric Ketchum

more ▼

answered Jun 11 '15 at 05:34 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image Priareos Jun 15 '15 at 05:18 PM

Hi Eric,

I found out what is cause for the problem by coincidence. It's the Anti-Aliasing within my Cameras Post Process Settings. If set to TemporalAA with Screen Percentage to 100, i get the Issue. Set to FXAA (unfortunately creates some other graphical artifacts) or Screen Percentage > 150, it's crisp as hell.

Just out of curiosity, how much of a performance killer would setting the Screen Percentage to 150 be?

Thx for your time and help!

Cheers

avatar image Lovecraft_K ♦♦ STAFF Jun 15 '15 at 05:52 PM

Hey -

I cannot give you an exact value, it will be a slight performance hit which may or may not be warranted in your project.

Sorry I cannot be more decisive without knowing more about the project.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question